3
\$\begingroup\$

I recently created my own breakout board for a STM32F030R8T6 MCU. The attached image shows the PCB that I designed for it. There are no components, only top copper tracks that get connected to header pins that is connected onto a breadboard.

Procedure:

  1. soldered the MCU on the PCB board and tested it for any short connections etc...
  2. Plug the PCB board into the breadboard and connect all the power and ground pins, I added 100nf ceramic capacitors as close as I could to the PCB board.
  3. Connect all the 10k resistors acccording to the schematic diagram
  4. Once that was done, I continued to connecting my ST link/V2 to the board, I only connected pins SWIO, SWCLK, GND & NRST (I left the VDD pin and TVCC pin as I understand it is only there to detect voltage).
  5. Connected my power supply to the power rails and applied 3v.
  6. Connect ST Link/V2 to laptop and open ST utility and try to connect to target.

This is where my problem starts. It says the programmer is unable to connect to target. I have tried everything from changing frequencies and connecting the MCU under reset mode, but nothing worked. So I looked at my power supply and I noticed that the current was varying between 10mA to 0.4A. Strangely the power supply didn't display that there was a short circuit. This is when I took my good old multi meter and did a continuity test and realized that my VDD and VSS pins are shorting.

I am not sure if my MCU is fried or if my ST link/V2 is faulty?

Extra Info:

I have tried resetting the MCU but that didn't do anything. There was a short period where I was able to connect to the MCU but after 3 seconds the utility program will give me a error message that it has lost connection with the target and that I must check my power rails which I did repeatedly.

I would gladly appreciate advice and help as I have gone through 4 MCU and I only have 2 left.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ Check if the power is wired backwards. Edit: VDD and VCC usually both designate the positive supply rail. Don't you mean VDD and VSS or VCC and GND? \$\endgroup\$ – kva Jun 6 '17 at 20:44
  • 4
    \$\begingroup\$ FYI, internally shorted and fried is the same thing. \$\endgroup\$ – Vladimir Cravero Jun 6 '17 at 20:46
  • 2
    \$\begingroup\$ So I meant VDD and VSS, I would like to add that I had connected a external power supply of 3v and then I connected my ST link/v2, sadly I have gone through 4 MCU units so far and I have one more left so I want to be sure that I get it right this time \$\endgroup\$ – user150963 Jun 6 '17 at 20:48
  • 3
    \$\begingroup\$ You maybe need to take a look : What is the difference between VCCVCC, VDDVDD, VEEVEE, VSS \$\endgroup\$ – M.Ferru Jun 6 '17 at 20:50
  • 3
    \$\begingroup\$ schematic would help us visualize any issues \$\endgroup\$ – Big6 Jun 6 '17 at 21:06
3
\$\begingroup\$

The updates in the question have helped clarify some points, although some concerns have not been answered, and the angle of the photos (not from directly above) makes it impossible to rule out connections to incorrect pins on the breadboard. However I can point out 2 problems so far:

  • Schematic shows decoupling capacitors, but they don't exist on the photo of the actual hardware.

    Even if some 100nF capacitors were fitted to the breadboard (as mentioned in the updated text, but not shown in the photo), that does not meet the requirements shown in the ST "Getting started with STM32F030xx and STM32F070xx series hardware development" document (see section 5.4).

    This could result in various problems, but is unlikely (in my experience) to cause permanent hardware damage as reported. Even if the cause of the hardware damage is corrected, you might still have problems (perhaps constant or perhaps intermittent) until the decoupling is also improved to meet the requirements.

  • No voltage is being supplied to the VDDA and VSSA pins (pins 9 & 8 on the LQFP48 package) - confirmed by the schematic and the photo of the breadboard.

    This is critical and these missing connections could cause internal hardware damage to the MCU. The datasheet and "getting started" documents explain more. Here is one example quotation to make the point clear (datasheet page 42):

    All main power (VDD, VDDA) and ground (VSS, VSSA) pins must always be connected to the external power supply, in the permitted range.

    On all the STM32 MCUs I have worked with, one common factor is that the documentation states you must supply power to VDDA and VSSA even if you are not using the ADCs. This is because an "analog block" inside the MCU (powered by VDDA and VSSA) also contains the power on reset circuitry which is always used, even if the ADCs are not used!

    Therefore as a minimum, you must connect VDDA to VDD and connect VSSA to VSS.

I have run out of time to investigate whether there are more problems and some things (e.g. power supply output spikes/ripple) have not been ruled-out. However that missing power supply to VDDA and VSSA needs to be at the top of your list of fixes, for your next attempt.

Read the documents that I linked to see the official ST recommendations for a minimal STM32F0 system.

Update: I am concerned about the missing connections to the ST Link/V2 which you mention. Some JTAG adapters require connections to the target's power, for their internal buffer ICs. I don't know about the ST Link/V2, and I don't have time to research it now. If I was in your situation, I would check this point.

\$\endgroup\$
  • \$\begingroup\$ I did everything you advised with no luck still, I have added a link for a video on Youtube to show you how it is behaving and I cannot connect to the MCU with my ST link, I did a continuity test before I connected the ST link and it was fine but as soon as I connect the programmer it shorts, can you help me? \$\endgroup\$ – user150963 Jun 7 '17 at 8:36
  • \$\begingroup\$ youtube.com/watch?v=2nVctdkyXeE&feature=youtu.be \$\endgroup\$ – user150963 Jun 7 '17 at 8:36
  • 1
    \$\begingroup\$ @user150963 - Unfortunately I cannot see enough detail in the video. However the decoupling still does not seem to meet the requirements explained in that ST document. You claim again that your MCU "shorts" but I see no evidence of that in the video. All I can say is that I suspect you have multiple problems, and are mixing up the diagnosis of each one, leaving you confused e.g. power supply to VDDA; decoupling; all necessary connections to the ST Link/V2 (the error message on the screen was not readable for me). Perhaps someone else will see information in the video, which I cannot see. \$\endgroup\$ – SamGibson Jun 7 '17 at 12:03
  • \$\begingroup\$ Thanks for all the effort you made, it taught me alot, I am just going to restart the whole design from scratch again :). \$\endgroup\$ – user150963 Jun 7 '17 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.