1
\$\begingroup\$

I want to use MSP430 launchpad to control a switch working between 1.65V and 2.75V. So, I wanted to force Vcc value to 2V instead of 3,3V while it is connected to my PC. I connected Vcc and GND pins to a power supply delivering 2V. But, now, I have a real problem. Even after taking off connection cables, Power led blinks and Vcc varies between 0V and 3,3V. I think that my kit doesn't work anymore. Could you tell me if it is the case.

Fortunately, I have another kit, I decided to work with it. But I don't know to force my Vcc to 2V to control my switch while the launchpad is connected to my PC.

Thank you very much ! Alice

\$\endgroup\$
  • \$\begingroup\$ Can you still upload code to a msp with the launchpad ? \$\endgroup\$ – M.Ferru Jun 7 '17 at 11:21
  • \$\begingroup\$ Which LaunchPad? \$\endgroup\$ – CL. Jun 7 '17 at 11:24
  • \$\begingroup\$ No I can't upload code anymore. \$\endgroup\$ – alissa Jun 7 '17 at 12:19
  • \$\begingroup\$ It is MSP-EXP430G2 launchpad \$\endgroup\$ – alissa Jun 7 '17 at 12:20
0
\$\begingroup\$

Since you connected the 2V supply directly to VCC while the board is powered, the regulator on board is delivering 3.3V to the VCC through the USB as well. This means that you are connecting a lower potential supply (2V) directly to a higher potential one (3.3V) and depending on the current sink capability of the 2V supply it may appear like a short to the regulator, very likely frying it in the process.

Try testing the old MSP430 chip with the new board, if it works then that means your old board is fried.

To power the board with 2V, DO NOT connect the launchpad to USB or any other supply. If you must need to connect the launchpad to your PC, then you should look into "voltage translation" circuits that translates 3.3V signals from your MSP430 to the supply voltage of the switch.

\$\endgroup\$
  • \$\begingroup\$ Yes that is what I did. And now I am sure that I fried my board. Based on what you said, I think that the best solution (most simple) is to upload the code and then disconnect PC and power the board with 2V. So that I am not obliged to use a "voltage translation circuit". What do you think ? Thank you very much \$\endgroup\$ – alissa Jun 8 '17 at 12:29
  • \$\begingroup\$ My problem now that I tried to do this with a simple example (LED blinks when button pushed) it does work only when my board is connected to PC. I thougth that normally it works since the code has been uploaded before disconnecting PC and connecting 2V power cables. What should I do ? \$\endgroup\$ – alissa Jun 8 '17 at 13:22
  • \$\begingroup\$ It is OK I understood what was the problem. 2V is an insufficient voltage to dwitch on the microcontroller LED. I tried with VCC > 2.5 V and It is ok it is working normally ! \$\endgroup\$ – alissa Jun 16 '17 at 8:03
  • \$\begingroup\$ Glad to know you were able to get it to work! Yes most LEDs will have a forward voltage greater than 2V so that's why it didn't light up. \$\endgroup\$ – Tony K Jun 20 '17 at 1:37
0
\$\begingroup\$

Every launchpad have a built in regulator that power the chip during code upload. Changing that voltage level on the launchpad may be difficult and very time consuming.

However, you can extract the mictrocontroller from the launchpad to power it on a breadboard (2V or so). To upload the code, you will need to connect the Test, RST and the ground pin to the launchpad. You have to take care of the voltage value of Test and RST. Those voltage will be at 3.3v (because there are coming from the launchpad), you will have to lower them to Vcc.

schematic

simulate this circuit – Schematic created using CircuitLab

Note that the voltage adapt has to be bidirectional, the MSP430 send some message to the launchpad as well.

\$\endgroup\$
  • \$\begingroup\$ Thank you very much, this was very clear. But, in this case, could I simply use the voltage adapter between the lunchpad pin that controls the switch and this last one ? And, could you please tell me how can I realise/ or get a 3,3V / 2V voltage adapter ? \$\endgroup\$ – alissa Jun 7 '17 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.