0
\$\begingroup\$

I want to connect Garmin 18x 5hz GPS (this) to computer via FTDI Serial TTL-232 USB Cable (this). But once I try to update the GPS via Garmin updater, I get framing error. "A communications error has occured. The hardware detected a framing error. Please ensure that the GARMIN device's Interface option is set to GARMIN or Host mode and try again."

This happens after I have chosen COM port and baud rate and click "OK" in the updater. I am not sure which baud rate I should use but Garming gives me 5 options in the updater (9600, 19200, 38400, 57600, 115200) and none of them work.

I have connected every wire individually, both GPS grounding wires into adapters grounding wire (blacks together), GPS' TXD into adapters RXD (white to yellow), GPS' RXD (RCV) into adapters TXD (green to orange) and red power cables together. Now after updating the adapters drivers and connecting the cable the adapters starts to flash green light (but not red). When I run the GPS updater the green light starts to flash for few seconds and then shuts off and error message pops up.

Is my wiring the problem (I just pushed the wires inside the other end of the adapter) or is the problem software side? Any suggestions or tips how I can connect the 18x 5hz through USB port?

EDIT:---------------------------------------------------------------------------

Thank you Andrew!

Now I need new adapter or MAX232 (or similar). Problem is the Garmin 18x 5hz only has cables on the other end that I can't connect to typical adapter. I have one serial port (RS232) to USB adapter lying around somwhere. I try to hook it up somehow into the Garmin and post results. I lack any soldering equipment or experience really...

EDIT2:--------------------------------------------------------------------------

I tried out the FT Prog and inverted the RXD and TXD signals but I still get the same problems as before. I also tried to invert every signal. After that did not work out either I dug up an old USB to RS-232 converter, but as I predicted, I really have no way to connect the Garmin GPS and typical RS-232 male port.

So either the problem lies in the GPS it self or the connections, because inverting the signals did not work. Thank you for the help!

\$\endgroup\$
1
\$\begingroup\$

The Garmin uses a somewhat bastardized version of RS232 that is designed to work with most PC serial ports. It is using RS232 signalling but without a proper driver IC so the signal voltages are 0-5V rather than the full +/- range RS232 should use.

The cable you have is for connection to a TTL (logic) level UART. You need to add a line driver to get the correct signal levels to connect to a normal RS232 port.

In other words they are both using 5V compatible signalling but the Garmin is connected as if it had a driver, the FTDI is connected as if it needs one. The driver ICs not only boost the voltage, they also invert the signals.
Your data lines are 0 when they need to be 1 and 1 when they need to be 0.

The simplest solution would be to use a normal RS232-USB converter rather than a TTL level one. Failing that you need to invert the signal levels or add a line driver to the FTDI cable.

\$\endgroup\$
  • 1
    \$\begingroup\$ The FT232RL (which adafruit claim is used in this cable) has a built in EEPROM and programable inversion, so you can invert the serial lines without any extra hardware. Just use FT_PROG to change the settings. \$\endgroup\$ – Peter Green Jun 8 '17 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.