4
\$\begingroup\$

When View --> Mark Data Points is selected on the waveform, LTspice shows data points unevenly separated along the time axis.

enter image description here

Does anyone know what do these points correspond to? It doesn't look like sampled points.

\$\endgroup\$
9
\$\begingroup\$

My guess is that these are the (time) points which the circuit simulator has actually solved.

Many analog circuit simulators, unlike simulators for digital circuits (logic), do not use a constant timestep. What these analog simulators do is calculate more timepoints when a lot is "happening" in the circuit and less points when things are more static.

I'm guessing that the circuit you're simulating has one or more CMOS inverters in it, these "flip over" around half the supply voltage (here 2.5 V) notice how there are more points when the voltage is around 2.5 V.

Often there is an option in the transient simulation settings which sets the maximum timestep. I almost always set that to 1/1000th of the total simulation time so that I get at least 1000 timepoints.

I have seen simulators where not forcing more timepoints gives wrong results. In an oscillator circuit the circuit would appear not to oscillate until I set the maximum timestep. Then the simulator suddenly noticed it was an oscillator and the oscillation was simulated as expected.

\$\endgroup\$
  • \$\begingroup\$ That plus compression of the data saved for plotting. .opt plotwinsize=0 to disable that compression \$\endgroup\$ – PlasmaHH Jun 13 '17 at 19:03
  • \$\begingroup\$ @Bimpelrekkie Interesting. Do you know the default "maximum timestep" relative to simulation time? Seems less than 1000 timepoints according to what you say. \$\endgroup\$ – atmnt Jun 13 '17 at 19:23
  • \$\begingroup\$ That depends on the simulator, consult the manual for the default. Indeed often the default forces less than 1000 time points as this makes the simulation run faster. It depends on the circuit if the default is OK or smaller timesteps are needed. If in doubt, run the same simulation twice, with default max. timestep and with a smaller timestep. Then check if the simulation result is any different. \$\endgroup\$ – Bimpelrekkie Jun 13 '17 at 19:51
4
\$\begingroup\$

The LT spice solver uses an adaptive time step numerical solver meaning that it chooses an arbitrary time step depending on how fast the signals are changing.

The default timestep is 1/50th of the simulation time, however the algorithm will go to a smaller time step if needed to maintain numerical accuracy.

There are a few things you can do to help this problem:

1) Set the maximum timestep to a smaller value, you'll get more points but you can make sure everything is being captured.

2) The main thing is set TRTOL in the simulation settings to 1 this will lessen the adaptive-ness of the simulation

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.