1
\$\begingroup\$

I am working on a schematic design in Altium Designer 17.1 that makes use of the Repeat() command for a child sheet. I have a certain sheet repeated 8 times for 8 channels of the device.

enter image description here

However, when printed out, the schematic shows all 8 sheets with the slightly different designators for each component (this is as it should be), but the sheet number (a parameter defined in the Document Options dialog) is duplicated for all channels.

Schematic:

enter image description here

Document Options "Sheet Number" parameter:

enter image description here

Having 8 "Sheet 2"s in the schematic printout is obnoxious and terrible practice. Is there a way to modify the parameter so that it increments for each channel? For example, instead of having Sheet 0 (hierarchy overview), Sheet 1, and 8 Sheet 2s, I would like Sheet 0, Sheet 1, Sheet 2, Sheet 3... Sheet 8, and Sheet 9.

EDIT: I have found out how to display the individual duplicate sheet numbers as Sheet 2.1-2.8, but I would like it to display whole-number sheets instead of decimals. Additionally, when I use the 2.X option it changes the total sheet number to 10 for just the repeated sheets, and having 2.8 sheets of 10 is not what I'm looking for.

enter image description here

EDIT2: I solved part of the problem. There is a tool buried in Altium called "Annotate Compiled Sheets", found in Tools -> Annotation -> Annotate Compiled Sheets. In this dialog the user is allowed to manually enter Sheet Numbers for each of the sheets, including the repeated ones that do not show up in the "Projects" panel.

enter image description here

However, the Sheet Total still shows "10", even though I changed it to "9".

enter image description here

Also, when I run the OutJob the individual sheet numbers do not carry through to the final schematic. They show up correctly in Altium, but when printed it only shows "Sheet 2" every time.

\$\endgroup\$
4
  • \$\begingroup\$ So I ended up getting rid of the Sheet 0 and just started at 1, so I have 10 sheets total. Printing from the Altium Outjob had to do with a setting in the "Schematic Prints" "Configure" dialog -- I had to check "Sheet Number Parameter" under "Physical Name Expansion". This printed the correct page numbers. \$\endgroup\$ – DerStrom8 Jun 15 '17 at 14:51
  • \$\begingroup\$ Hmm, now I'm having the same problem with "DocumentNumber", except that Annotate Compiled Sheets doesn't have the Document Number as a parameter that is editable \$\endgroup\$ – DerStrom8 Jun 15 '17 at 15:01
  • \$\begingroup\$ Hey, your solution is a great answer. Could you copy/move it to an answer and accept it as the right one to improve this site's reference material? \$\endgroup\$ – tyblu Jun 15 '17 at 17:28
  • \$\begingroup\$ I hadn't completely solved the problem, it was partially just a work-around, but I have moved what I could into an answer. It will not let me accept it for another couple of days though, due to how the system is set up. \$\endgroup\$ – DerStrom8 Jun 15 '17 at 17:37
2
\$\begingroup\$

I have solved the problem. There is a tool buried in Altium called "Annotate Compiled Sheets", found in Tools -> Annotation -> Annotate Compiled Sheets. In this dialog the user is allowed to manually enter Sheet Numbers for each of the sheets, including the repeated ones that do not show up in the "Projects" panel.

enter image description here

Once these have been modified, in order to get it to print the page numbers correctly, in the Altium OutJob under the Schematic Prints configuration you must select "Sheet Number Parameter" under "Physical Name Expansion". This prints the correct page numbers.

In order to get the above to work, however, I had to get rid of the "Sheet 0" indicator and start the numbering at "Sheet 1" instead. Apparently Altium doesn't like starting at Sheet Number 0.

EDIT: For future reference regarding the following comment:

Now I'm having the same problem with "DocumentNumber", except that Annotate Compiled Sheets doesn't have the Document Number as a parameter that is editable

If you are printing to a PDF using the "Smart PDF" tool, on the second-to-last pane ("Structure Settings") you'll need to check the "Use Physical Structure" box and check all of the other boxes except "Document Number Parameter".

If you are printing to a PDF using an OutJob, after creating the PDF output, right-click it and select "Configure". Under "Physical Name Expansion" check all boxes except "Document Number Parameter".

Provided the Document Number parameter field is set correctly, the above will remove the ".1"-".X" suffix on the end of the parameter, which was an issue I had with the sheet number at one point.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.