0
\$\begingroup\$

I decided that I will be soldering airwire to one of the pins of existing SMD devices directly (e.g. to capacitor terminal) - there's no space for through-hole wire mounting pad, and soldering to terminal soldered to pad should be more mechanically reliable than soldering wire just to its dedicated SMD pad.

If I give same name to signal at each side of airwire I will have airwire in the board editor, and I want to eliminate it. If I give signals different names, while "output" side of airwire passes ERC properly, another side is having input only, and gives an error. I of course can accept this error, but looking to the way making it "clean".

I tried to make SMD pad terminals for each side of airwire, but putting it onto the resistor/capacitor pad logically gives "overlap" error. Is there any other hacking way I can tell EAGLE that it should not draw airwire?

\$\endgroup\$
1
\$\begingroup\$

If there is only one connection on that net, then the simplest approach is to just hide the airwire. You can do this using the command:

ratsnest ! signalName

Where you replace signalName with the name of the net you want to hide. To make it visible again, simply omit the !.

The reason I say if there is only one connection is that if your wire was making up only part of a larger net, hiding the airwires for that net could hide a missing connection elsewhere on the board.


A neater approach would be to split the net up as you say, naming each end of the net. But then add an additional test pad to each end. There is a standard library called testpad which has single SMD or PTH pads. If you add one of these to each end of the net, and you can then attach the wire to this pad. If you don't have space, choose the smallest SMD pad option and place it on top of your existing pad in the layout.

To avoid getting overlap errors in this arrangement, you should set the "Clearance -> Same Signals -> Pad" and " -> SMD" settings in the DRC window to be 0. This will disable checking of overlapping pads.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ If I put it in top, I get overlap error in DRC. Any other way than just accept it? \$\endgroup\$ – Anonymous Jun 16 '17 at 9:32
  • \$\begingroup\$ @Anonymous you should only get overlap errors if the pads are on different nets. By using the testpad and ensuring it is on the same net as the pin it is overlapping you shouldn't get those errors because they are electrically connected. A screenshot might help. \$\endgroup\$ – Tom Carpenter Jun 16 '17 at 9:38
  • \$\begingroup\$ What is your DRC setting for "Clearance -> Same Signals -> Pad" (and "-> SMD")? \$\endgroup\$ – Tom Carpenter Jun 16 '17 at 9:39
  • \$\begingroup\$ Ah, wait, it will if those settings are not both 0. If you don't mind pads overlapping, set the clearance to 0 and it won't throw up errors. \$\endgroup\$ – Tom Carpenter Jun 16 '17 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.