1
\$\begingroup\$

I want to add a parameter variant to my schematic. The parameter being varied, called "Load", does not exist in the DbLib from which I'm pulling my schematic symbols. Instead I've added the load parameter to certain symbols placed in my SchDoc.

I'm able to add a parameter variant changing the Load parameter from empty to "DNI" in the Variant Manager Dialog, but when I switch to the newly added variant in my SchDoc, I see no change to the "Load" parameter of the target symbol.

Any idea what I might be doing wrong from the above description?

thanks

\$\endgroup\$
1
\$\begingroup\$

When you change the variant the value in the schematic editor does not change. In order to view the variant differences you must select the variant-specific sheet, which is selected using the tabs at the bottom of your SchDoc. I don't have one set up at the moment to show you, but hopefully you will be able to find it on your own. Switch to the variant with the modified value for "Load" and the extra tab(s) should appear at the bottom of the pane, next to the "Editor" tab. If it doesn't, after changing the variant close the SchDoc and reopen it, and the tab(s) should appear.

All this is from memory, so hopefully it still works for you. I can look into it again when I get to work tomorrow -- I have various projects with multiple variants.

\$\endgroup\$
  • 1
    \$\begingroup\$ Selecting the variant tab (next to editor tab) at the bottom left did the trick. Thanks! \$\endgroup\$ – Yoshimitsu Jun 23 '17 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.