0
\$\begingroup\$

I just found this site and read a few great interesting articles but nothing that would solve my problem I am hunting since a while.

I have a OpAmp circuit with a N-FET source follower that regulates the current of some LED's. LED current is set at 700mA. The ripple on the LED voltage source is at around 590kHz and is seen at 20mV on the source shunt of 0.3R. This feedback goes directly to the OP-. The OP+ has a quite stable reference voltage. This means I can measure a 20mVpp ripple between OP+ and OP-! When I measure the OP output and OP- I see that both signals have the same phase and are NOT inverted. This means that 20mVpp on the 0.3R shunt generates 40mV on the gate of the FET with the same phase. But it should be the opposite. So I guess the OP is not stable at this frequency. Otherwise it works fine and regulates the current accurate and quick. It's just that there is lots of ripple noise (and thus current ripple) and I would like to get rid of it! What am I not seeing or did wrong here? Any hints would be appreciated!

LedDriver

Here a scope picture. The reference voltage at OP+ is stable. But I can measure a 20mVpp ripple between OP+ and OP-! This means the OpAmp is not really doing what it should do.

On the picture is the gate voltage with the shunt voltage as comparison. The shunt voltage (OP-) is yellow with about 20mVpp ripple. The pink is the gate voltage at around 1.75V and it has the same ripple but with the same phase and 40mVpp. I always measured with the short, spring type GND connectors on the probes and took the OpAmp GND as reference.

OP- vs. Gate voltage

So my question is here: why doesn't the OpAmp try to remove the ripple as the feedback of the source is directly connected to OP-? Why is it running at the same phase? The GBW is at 2.2MHz. Isn't this circuit running at unity gain? What am I missing? Thank you very much for any hints/inputs!!!

\$\endgroup\$
  • 1
    \$\begingroup\$ Are you maybe picking up noise from a switching power supply somewhere? Have you tried with very short leads on your scope probe (using a spring probe instead of the ground lead on your scope probe?) \$\endgroup\$ – JRE Jun 30 '17 at 11:22
  • 1
    \$\begingroup\$ Possible duplicate of Stability problem in unity-gain opAmp \$\endgroup\$ – brhans Jun 30 '17 at 11:25
  • 1
    \$\begingroup\$ ... And electronics.stackexchange.com/questions/313170/… \$\endgroup\$ – brhans Jun 30 '17 at 11:26
  • \$\begingroup\$ You have an unused op amp in your circuit. If this is left floating as shown, it will likely cause oscillations. \$\endgroup\$ – Glenn W9IQ Jun 30 '17 at 11:32
  • \$\begingroup\$ Open OpAmp is used, i just removed the components to make it clearer... \$\endgroup\$ – 6o4o Jun 30 '17 at 13:46
2
\$\begingroup\$

You have oscillations because there is a chance that the circuit is unstable due to the gate-source capacitance of the MOSFET adding significant phase shift within the negative feedback closed loop containing the op-amp.

Simple analysis would make you think that because the MOSFET is connected as a source follower (regarding negative feedback) any gate capacitance will be neutralized but this isn't the case if you look into the detail. The gate source capacitance is about 1nF and approximately one-third of this will be "seen" by the circuit because MOSFETs are not perfect voltage followers. Your waveform shows this: -

enter image description here

Source voltage (yellow) is about 2/3 of gate voltage (pink) implying that between gate and source is a voltage of about one-third hence residual capacitance projected back to the op-amp output via the 100 ohm resistor is also about one-third. It should be noted that I have assumed the capacitance to be about 300 pF but, on further inspection of the DS it would be more like 450 pF.

So you have a 100 ohm resistor and approximately 300 pF (or maybe 450 pF) forming an extra phase shift. This will add 45 degrees phase shift at about 5 MHz. However, it doesn't mean that the circuit won't oscillate at lower frequencies - the phase shift will be less than 45 degrees of course but, if there is enough added phase shift to bring the phase margin down to zero at above unity gain, you get an oscillator.

Clues lie in this picture taken from the op-amp data sheet: -

enter image description here

It's not absolutely clear cut because TI (in their infinite wisdom) have not delivered a graph of pure open loop gain and phase so this is the nearest we can use. For the gain, anything above the red line is potentially able to oscillate. For the phase anything equal to the blue line will cause oscillations providing gain is above the red line.

As you can see, when 100 pF is placed on the output, the op-amp avoids turning into an oscillator i.e. phase margin becomes zero at about 3 MHz but gain has just dropped to about 7 dB below unity = no oscillation.

What is the loading effect of the 100 ohm resistor and residual gate capacitance (~300 pF)? Difficult to be precise but if it's like adding a 100 pF capacitor then it's a fair comparison BUT, remember the 100 ohm and ~300 pF add probably +30 degrees of phase shift around the loop at about 3 MHz so it'll oscillate, possibly about 1.5 MHz for a guesstimate.

The ripple on the LED voltage source is at around 590kHz and is seen at 20mV on the source shunt of 0.3R

This is significantly below the 1.5 MHz that I estimate but the mechanism outlined above cannot be ruled out given the lack of proper information in the data sheet. At 3.3 volts the phase margin may be worse for instance. My estimate for residual gate capacitance might be significantly low as well. Poor grounding may also contribute.

Remember also that the LEDs are fed from an independant supply (9.5 volts) that may have significant ripple at 560 kHz and this will not be greatly reduced by the op-amp because it only has a gain overhead of about 15 dB i.e. it won't cope well with this as a disturbance.

\$\endgroup\$
  • \$\begingroup\$ Nice way of explaining things +1 .When I was at UNI I specialised in repeating control systems . \$\endgroup\$ – Autistic Jun 30 '17 at 12:39
  • \$\begingroup\$ Great, thank you very much Andy! I had the feeling about the gate cap and the other links brhans posted where you also answered on that topic but I could not explain myself on how exactly it works. Now i understand it better! Now i will try the 2nd link (of brhans) where a cap is put from output to Op- as feedback. \$\endgroup\$ – 6o4o Jun 30 '17 at 13:53
  • \$\begingroup\$ @6o4o the other answer was a slightly different scenario - the output was truly at the emitter (or source) and the load would not be so low that gate-source capacitance would be a big problem and generate significant residual capacitance. Your feedback resistor is only 0.3 ohms and below an ohm you really need to look at the phase shift. As a fix, you could try lowering the 100 ohm resistor and, if it isn't that, maybe it's noise coming from the 9.5 volt rail. \$\endgroup\$ – Andy aka Jun 30 '17 at 13:59
  • \$\begingroup\$ I lowered the 100R to 0R, changed nothing. Yeah, the 580KHz comes from the 9.5V , it's a DcDC! But i expected the OpAmp to fight the noise and keep the current constant with no ripple. The OpAmp voltage (3.3V) is from an LDO and it had no noise at all. \$\endgroup\$ – 6o4o Jun 30 '17 at 14:56
  • \$\begingroup\$ @6o4o - my last paragraph in my answer says effectively the following - when the open loop gain is low, you cannot expect an op-amp to cope as it would when the open-loop gain is high (lower frequencies or DC). At 580 kHz, the open loop gain looks like 15 dB and this is pitifully small to expect an op-amp to regulate out the modulating current from the 9.5 volt rail. It's all down to the equations for errors in op-amps. \$\endgroup\$ – Andy aka Jun 30 '17 at 17:25
0
\$\begingroup\$

Operating close-to-rail, the Rout becomes higher and higher.

Assume 1Kohm Rout (TI gives no data nor curves, just how drive strength collapses near the rails) at VDD/2, and 10Kohm if "close to rails".

With 1MHz UGBW and 10Kohm, the equivalent inductance is (1uH and 1MHz is j6.3 ohm) 1,600uH.

Fring of 1,600uH and 300pf (Andy aka Cin number) is sqrt[25,330/(Luh*Cpf)] in MHz. Fring(MHz) is sqrt(25,330/1,600*300) or sqrt(25,550/500,000) or sqrt(1/20) or 0.2MHz

What is your Fring?

\$\endgroup\$
  • \$\begingroup\$ 580khz is the ripple BUT this comes from the DCDC that provide the 9.5V... \$\endgroup\$ – 6o4o Jun 30 '17 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.