0
\$\begingroup\$

I am really new to PLCs programming, connecting, etc. I received a 1756-L72 with Logix5572 Processor and an EthernetIP card. My goal here is to connect it to my laptop along with another device (a Bar Code Reader). Both devices are connected to an unmanaged ethernet switch and one of the port to my laptop.

Now the problem is that all my Rockwell Softwares are on a VM. Therefore, I need to connect all those devices to the VM on my laptop and it does not seem to work. My ethernet IP on the VM is 192.168.198.128 while my PLC is 192.168.0.205. I know i have to get the 3 first equal but I don't know how to change my PLC IP address. I tried following this website steps but it did not work.

I know it might not be clear, so I'm available to answer any questions you guys have.

Thanks, luisarcher

\$\endgroup\$
1
\$\begingroup\$

This site is really for electrical / electronics design questions so your question isn't a great fit. However ...

On VMWare, and I presume most other VM software, there is an option on the VM settings to configure your network connection as NAT or bridged. You have two choices:

NAT

  • Configure the IP address and subnet mask you want on the host machine.
  • Set the VMWare to NAT. It will then pick up the host address.

Bridged

  • Leave the host PC as is.
  • Configure the IP address and subnet mask on the VM.
  • Set the VMWare to Bridged.

It's often much easier to use a router with DHCP enabled. Configure it with the browser interface to the PLC subnet (using a unique IP address) and then let the PC obtain its address by DHCP. In this case you would use NAT for the VM settings.

Mr. PLC and PLC Talk are great sites for help with industrial controls.

\$\endgroup\$
  • \$\begingroup\$ Alright, I'll try my luck on those sites. Thanks for your help ! \$\endgroup\$ – luisarcher Jul 5 '17 at 16:42
  • \$\begingroup\$ Thanks for accepting my answer but did you try my suggestions and did they work? \$\endgroup\$ – Transistor Jul 5 '17 at 17:10
  • \$\begingroup\$ I know the NAT one is not working. I changed my network connection to Bridged and now I don't have Internet Connection in my VM. I'm trying different setups on RSLinx but I'm still unable to see the PLC (i tried pining it with no luck) \$\endgroup\$ – luisarcher Jul 5 '17 at 17:17
  • \$\begingroup\$ right now I'm trying to change my PLC's IP to fit my subnet which is 169.254.118.x \$\endgroup\$ – luisarcher Jul 5 '17 at 17:18
  • \$\begingroup\$ Let's discuss in chat. \$\endgroup\$ – Transistor Jul 5 '17 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.