1
\$\begingroup\$

I am using a SPF240D25R Solid State Relays - PCB Mount PCB SIP 240VAC, 25A load current and 4-15VDC trigger voltage. This is being triggered from a ULN2003A and used to drive a motor (pump).

On the same board I am driving a 5V coil relay which has 12VAC across its contacts with no load, this two is driven from another transistor with the same ULN2003A device.

When I fire the relay the SSR is firing. When I turn off the relay the SSR turns off. This ONLY happens when the load (motor) is connected to the SSR. For example, if I fire the relay and the measure the O/C load on the SSR it does not fire.

I cannot figure out the problem. I have a 100 ohm || 1uF capacitor snubber on the input to the SSR. I have a 1N4001 flywheel diode across the relay coil (even though the ULN2003 has them).

The main thing which is confusing is what does it not fire in error when no load is connected to it?

EDIT:

This is part of a large system and the schematics are over multiple pages. I have provided the various snippets below.

This is the SSR circuit. Please note that the SSR is a SPF240D25R (ignore the name on the schematics). Also note that the "pump relay" is not the offending relay. In fact when this relay is fired the same problem is NOT witnessed. enter image description here

This is the lighting relay (recently added flywheel diode not shown) enter image description here

\$\endgroup\$
  • \$\begingroup\$ Maybe the problem lies in the PCB layout. \$\endgroup\$ – Andrew Morton Jul 8 '17 at 21:34
  • \$\begingroup\$ @AndrewMorton - it may ... and I have lifted some pins to try and isolate the problem - but it persists. \$\endgroup\$ – tomdertech Jul 8 '17 at 21:40
  • \$\begingroup\$ Schematic please \$\endgroup\$ – Voltage Spike Jul 8 '17 at 21:43
  • \$\begingroup\$ @laptop2d - I have added 2 schematic snippets (not enough reputation points to do more) so here is the ULN2003 snippet - prntscr.com/ftb6j3 \$\endgroup\$ – tomdertech Jul 8 '17 at 22:10
  • \$\begingroup\$ Do you have a minimum load on the SSR when you are measuring its "open circuit" behavior? Due to leakage current and SCR latchup, you won't get sensible behavior without some load. \$\endgroup\$ – Evan Jul 8 '17 at 22:28
1
\$\begingroup\$

SOLVED - it turns out that the GND (pin 8) was floating. So even though it triggered other SSR and relay fine, it suffered from this interference. It would have been easier to find had it not worked at all!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.