I have been repairing the jack for my pair of Sennheisers for Android (I have done 3 attempts so far) but I can't seem to make the volume controls work.

To clarify, after the repair, the sound is alright, the microphone also works but none of the buttons work.

I am not sure what I have done wrong. The soldered connections are all ok, at least it seems like they are ok.

There are 6 wires in total, 3 grounds and 1 for right sound, 1 for left and 1 for mic, something like this:

4 pole headphones wires

Then what I soldered the mic, right, left wires to the their corresponding positions, and then I soldered all 3 ground wires to the ground position (not sure if the grounding of all 3 ground wires together is correct), the positions look like this:

4 pole jack

What have I done wrong?

Many thanks for your help,

Edit 1:

As Chris pointed in one of the anwers, the reason why the buttons were not working was because android uses CTIA specification and I wired things based on OMTP - a comparison is shown below.

CTIA vs OMTP

After a rewired things based on CTIA as below, everything worked as expected.

connections

Edit 2: Marking this question as answered although there is still one minor problem with the stereo where the right audio sounds very "echo-y" and not normal - for another thread.

  • If you want to do some explorations from the unconnected wires, this is probably what the phone wants to see source.android.com/devices/accessories/headset/… – Chris Stratton Jul 9 '17 at 11:56
  • The problem with the sound being echo-y was due to the bad replacement jack - after I got a new jack from another brand and re-did the repair the sound is perfect. – ld_pvl Sep 28 '17 at 23:51
up vote 1 down vote accepted

You have wired your connector according to the OMTP standard, with microphone on the second ring and ground on the final sleeve.

However, according to the general Android microphone specification Android normally expects CTIA wiring "Except in regions with legal requirements for OMTP pinout".

CTIA wiring places the common ground on the 2nd ring, and the microphone on the final sleeve.

Most likely, if this is your wiring problem, you would find that you don't have any microphone input (or you get by odd means), and that you have no stereo separation, since your speaker drivers may be effectively in series with one another and without any actual ground.

Of note, the Android document linked above also includes the expected wiring of headset function buttons to ground through resistors of specified value.

  • Many thanks! I didn't know about CTIA - I will make my 4th attempt and report back. – ld_pvl Jul 9 '17 at 19:09

make sure that the shell on the wire is completely cleared then start your soldering

how clear the shell : 1- you can burn the wire and then clean it with a napkin 2- use the tipe of soldering iron(Scrub it)

  • Welcome to EE.SE. Please use proper standard English capitalisation and punctuation. This will make your posts more readable and add to your credibility. – Transistor Jul 9 '17 at 12:02

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.