2
\$\begingroup\$

So I use Altium for designing and on most days a quick restart generally makes things normal. But today Altium refused to start at all.

I could see in task manager multiple instances of Altium though all were frozen.

Any way to get the Altium to run or do I need to uninstall and install the whole thing again?

Also any ideas why such a thing would happen so any mistakes can be avoided in the future?

Thanks!!

\$\endgroup\$
  • 1
    \$\begingroup\$ This has happened to me before. Not sure how I fixed it, but a workaround that worked for me is. Rather than opening the program, try opening an altium file instead. \$\endgroup\$ – Doodle Jul 13 '17 at 7:24
  • \$\begingroup\$ Tried that! Schematic, PCB, PCB project, Library. Nothing seems to force it to open \$\endgroup\$ – Sachin Jul 13 '17 at 7:25
  • \$\begingroup\$ Not really a EE.SE question, but I think little troubleshooting would go a long way. Restart? If that doesn't help. Uninstall. \$\endgroup\$ – ammar.cma Jul 13 '17 at 8:10
  • \$\begingroup\$ Do you often have a large number of files open in Altium? Multiple projects, or just one project with lots of source files? \$\endgroup\$ – DerStrom8 Jul 13 '17 at 10:54
  • \$\begingroup\$ If you removed a file since you last started it that was in your workspace, it might not look like it's running but will be and have popped up a small dialog box somewhere on your monitors to close first before it will run. That dialog box basically just says cannot find file xyz.abc in project. \$\endgroup\$ – Joel Wigton Jul 14 '17 at 5:17
1
\$\begingroup\$

This happens to me quite frequently. A couple of things to try.

Try opening the workspace directly. If you save your workspace into a specific folder, then use that workspace. On Windows 7 my workspace defaults to C:\Users\sglover\AppData\Roaming\Altium\Altium Designer {B7BBF47B-2F84-45EA-954F-607E59116D16}\LastWorkspace. Yours may be similar.

If that doesn't work then you may need to delete the workspace and all of the temporary files that Altium creates. On my Windows 7 PC these are in 2 places:

  • C:\Users\sglover\AppData\Local\Altium
  • C:\Users\sglover\AppData\Roaming\Altium

The safest way is to rename these Altium folders to "Altium old", then try restarting Altium. You will need to "kill off" any instances of Altium that are still running by using the Task Manager first.

\$\endgroup\$
  • \$\begingroup\$ I'm marking this as an answer although I couldn't try the suggested method. (assuming it works!) \$\endgroup\$ – Sachin Jul 25 '17 at 10:05
  • \$\begingroup\$ Thanks! I have solved the same problem by using your method. Specifically, delete the files in the "C:\Users\xxxx\AppData\Roaming\Altium\Altium Designer {xxxxxx-xxxxx-...}" and not required to delete subfolders. Then it is working now. Thank you very much. \$\endgroup\$ – Seungchan Lee Sep 13 '18 at 17:54
0
\$\begingroup\$

I had something like this with many "thead" issues. popping up. I think it has something to do with too many tabs open. I managed to get it running by:

  1. right clicking the taskbar icon and starting a 2nd instance with no documents open.
  2. Kill with task manager the failing instance and leave open the new instance.
  3. close all the projects
  4. close altium
  5. start up altium again.
\$\endgroup\$
-1
\$\begingroup\$

This works.

Rename the file in \roaming as OLD_ and restart.

Then reload all your defaults.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.