0
\$\begingroup\$

I'm a beginner with Altium Designer 17.1 and I'm facing difficulties. I'm designing a PCB but when I compile the project this error is shown.

I'm using ports, they are set on global.

Also, I'm having another problem. I made a NMOS Schematic and this error is shown : enter image description here

I made the pins and everything worked fine (this error isn't shown in the compilation, only the error above) but when it comes to the PCB, they are implemented on the PCB but aren't linked to other components.

Thank you for your help.

\$\endgroup\$
1
\$\begingroup\$

First and foremost: Always make sure to hit Project -> Recompile instead of Project -> Compile (Recompile will take all sheets into account, not only the one you're working on). The first error should disappear. If not, make sure that the pins are actually connected (can be an issue when you're designing in a metric system for the schematic as Altium will usually use DXP units (which are imperial). Also let us know your settings in the project properties (Hierarchical, Automatic, ...).

As for the second issue. You need to match the Pin designator. Your schematic symbol probably has Pin Designators 1,2,3; your PCB symbol probably has Pin Designators (well, actually Pads) labeled G,S,D ... you need to choose one over the other. Those must match.

\$\endgroup\$
13
  • \$\begingroup\$ The first problem is solved, indeed I alyays hit Compile, great to know, thanks a lot. For the second issue, I matched the pins but it doesn't work. \$\endgroup\$ – Ultra67 Jul 18 '17 at 10:52
  • \$\begingroup\$ ibb.co/deqUZa I have this error too \$\endgroup\$ – Ultra67 Jul 18 '17 at 10:56
  • \$\begingroup\$ Component Class Members shouldn't worry you at the moment. This will be resolved once you sorted out Error #2. Can you post your Schematic Symbol and Footprint? Can you show the properties dialog of the schematic symbol? Can you show a screenshot from the following Dialog: Go into the PCB -> Project -> Component Links \$\endgroup\$ – Tom L. Jul 18 '17 at 10:58
  • \$\begingroup\$ Here you are : imgur.com/2IshjUX imgur.com/M8pUz8l imgur.com/2jiDXsu imgur.com/HAej8UI \$\endgroup\$ – Ultra67 Jul 18 '17 at 11:07
  • \$\begingroup\$ Looks pretty good actually (except for the GDS and 1,2,3 issue which I can't tell you yet). Can you double click on a Pin of the schematic symbol and post the screenshot of this pin properties dialog? Also, try to delete the part from your Altium schematic, then add it from the library. Altium will NOT automatically push changes from the library to the schematic (only through a Update Libraries command); Also a good idea: Open both footprint and schematic symbol, then in the library dialog, right click the symbol and select -> Update schematic sheets with symbol or footprint \$\endgroup\$ – Tom L. Jul 18 '17 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.