7
\$\begingroup\$

I am working on preamp input selector PCB in Eagle and I've run RATSNEST command for displaying airwires: Aiwries There are no airwires left as can be seen from screenshot, however, particular command reports to me in status bar: Ratsnest: 3 airwires

Why and if so, where are they so I connect them?

\$\endgroup\$
  • \$\begingroup\$ A simple trick to find airwires: Zoom out as far as possible, then use the net tool on your teeny tiny layout making it snap to the closest airwire. \$\endgroup\$ – Michael Jul 27 '17 at 17:32
11
\$\begingroup\$

There is a very useful eagle ULP called "zoom-unrouted" which if you haven't already got it, you can download here.

Save it in the ULP folder and then run it (run zoom-unrouted). Eagle will then zoom in to the first airwire.

Check for vertical (single pixel) airwires caused by ground plane islands, and for tiny gaps at the end of traces.

I can see from your screenshot there is one airwire between pins 7 and 10 of IC2.



On an unrelated point, make sure the "Isolate" value on your polygons is non-zero (it looks to be set to 0 to me) otherwise you will get Gerber files which are solid copper over the entire board (everything shorted out).

Also run the DRC with settings relevant to your PCB house as there appears to be quite a few places where there may be either shorts or clearance errors.

There's also an awful lot of redundant routing on the OUTPUT_LEFT and OUTPUT_RIGHT traces - unless you are going for star connected, you might want to revisit the routing of those traces.

\$\endgroup\$
  • 1
    \$\begingroup\$ "tiny gaps at the end of traces." This seems to be a common problem with Eagle when the routing grid is imperial and the components have a metric pitch (and vice versa). \$\endgroup\$ – Steve G Jul 27 '17 at 11:09
  • \$\begingroup\$ @Tom Carpenter, what do you mean with star connected, can you provide me with some link, will do redesign. \$\endgroup\$ – KernelPanic Jul 27 '17 at 11:40
  • \$\begingroup\$ @KernelPanic you have one trace called OUTPUT_LEFT running vertically up the side and then eight traces running horizontally to the various relays. Whereas you could just have two traces going horizontally to reach the two rows of relays. \$\endgroup\$ – Tom Carpenter Jul 27 '17 at 11:43
9
\$\begingroup\$

Deselect all layers except the 'Unrouted' Layer.

You shall see which connections are open.

\$\endgroup\$
6
\$\begingroup\$

This happens to me quite often and it is usually caused by a mismatch in grid sizes between components. You think you run a track to a component pad but unless it ends at just the right point, it's still considered disconnected. What I do in this case, since I can rarely add a track that short to jump the gap or recreate the old grid, is use the autorouter. This is the ONLY time I use the autorouter. Just do a quick run and have it fill in whatever is left (don't have it redo the entire board) and it should make the missing connections.

\$\endgroup\$
  • \$\begingroup\$ That is actually a valid reason for the autorouter. Had not thought of that before. \$\endgroup\$ – Jeroen3 Aug 7 '17 at 6:29
2
\$\begingroup\$

Run the DRC. DRC lists unconnected airwires as errors. Then you can click on the error to zoom unrouted net.

\$\endgroup\$
2
\$\begingroup\$

Another quick way that I use to find unconnected airwires is to zoom out from the board design until it is just barely visible, select the route option (as you normally do to perform routing) and just click over the board design. What will happen is that the routing tool will start routing from a missing airwire (just like you normally would). You can then zoom back in to where exactly the unconnected airwire is and continue routing as you would normally do.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.