1
\$\begingroup\$

I'm a newbie who's trying to simulate a Chebyshev filter for which I used the calculator at https://www-users.cs.york.ac.uk/~fisher/lcfilter in LTSpice. The behavior I'm seeing in LTSpice (XVII if that makes a difference) doesn't match what's predicted by the calculator.

Here's the circuit: Chebyshev highpass filter generated by website

Here's what's predicted: Graph with low values up to around 150 MHz, and high values beyond that

Here's what I built in LTSpice - definitely not a 171 MHz highpass filter based on the graph. Graph that looks more like a 1 kHz filter with no ripple

What am I doing wrong?

Arsenal pointed out in the comments that my range was obscuring things. I adjusted the range to show more reasonable values: Graph from -100dB to 100dB and phase angles

\$\endgroup\$
6
  • 1
    \$\begingroup\$ Hmm maybe your logarithmic scale of the y-axis is messing around with you? You have -1200 db on that thing. And what is the phase diagram looking like? \$\endgroup\$
    – Arsenal
    Aug 24, 2017 at 7:51
  • \$\begingroup\$ Added a more reasonable Y scale and phase angles \$\endgroup\$ Aug 24, 2017 at 8:03
  • 2
    \$\begingroup\$ Try setting the spice and simulation axes to the same type (lin or log) and the same range, say +20 to -100dB if log. By trying to compare decimal fractions of a kdB to 0 to 1 linear, you're on a hiding to nothing. Plot over only 150MHz to 200MHz, with a grid, so you can see what your frequencies are dong. \$\endgroup\$
    – Neil_UK
    Aug 24, 2017 at 8:07
  • \$\begingroup\$ @Neil_UK: exactly, doing it linear will show the same has his simulation graph \$\endgroup\$
    – PlasmaHH
    Aug 24, 2017 at 8:08
  • 1
    \$\begingroup\$ Additionally to replicate your simulation, click on the phase axis and untick the "unravel branch wrap" box \$\endgroup\$
    – PlasmaHH
    Aug 24, 2017 at 8:09

3 Answers 3

1
\$\begingroup\$

The are two problems. Firstly the graph you are trying to reproduce is linear, but you are plotting logarithmic amplitude. Secondly you are only computing one point per decade, so the 'curve' is made from just a few straight lines.

Change the sweep to linear with 100 points and left vertical scale to linear, then you should get something like this:-

enter image description here

\$\endgroup\$
1
\$\begingroup\$

The designed response curve has linear scale. Your updated simulation result still has decibels. They are difficult to compare. You should goto your simulation settings and remove the decibels from what is calculated. This is what the early commentators have actually suggested. It does not help if you try to scale the decibels. They are still decibels and need a little math to be converted to voltage gain.

The result coarsely seems to be the wanted high pass response, but shown in desibels.

\$\endgroup\$
1
\$\begingroup\$

enter image description here

I don't see the problem you see - I have modified your picture to approximately show the 3 dB point and it looks about 171 MHz to me. Here's a closer look: -

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.