0
\$\begingroup\$

I am using M74VHC1GT125DT1G a non inverting Buffer IC. See attached image . I have capture input and output waveform,problem is even when my input is constant high the output is switching.

MODEM TS is:- UART TX line of ARM 9 Processor

enter image description here

I doubt on ripple on input line. But when i checked datasheet is has below parameter. It looks line it can tolerate ripple. Any suggestion. enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ Capture both waveforms simultaneously. Does the output clean up or change when you stick the capacitive load of a scope probe on the input? Is the probe itself cleaning up the ripple? Do you have a pullup or pulldown on teh input or is it a high impedance antenna to pick up interference? \$\endgroup\$ – Brian Drummond Aug 28 '17 at 15:09
  • 1
    \$\begingroup\$ Please post a scope shot of the input voltage, with scope in DC mode, 0.5V/div, 0V at the bottom of the screen, and if your scope allows it, make sure it displays the Min and Max of the input signal. This is to ensure the input signal is either 0 (below 0.8V) or 1 (above 2V) which I can't see in the first scope shot since I have no idea where 0V is on screen... \$\endgroup\$ – peufeu Aug 28 '17 at 15:42
  • 1
    \$\begingroup\$ Also the datasheet says "the device can be used as a logic−level translator from 3V CMOS logic to 5V CMOS Logic" and "TTL−Compatible Inputs: VIL = 0.8 V; VIH = 2 V" so if the input is valid 3.3V CMOS levels it will work. But is it valid levels? Also check the gate's power supply with scope. Ferrite bead and 100nF cap make nice LC resonant circuit. You could have built an oscillator without knowing... \$\endgroup\$ – peufeu Aug 28 '17 at 15:44
  • \$\begingroup\$ You can see zero volt line as yellow lag on left side of capture screen, count row from bottom to till 2. thats me 0v , volt scale is 1v per division, so in top figure waveform is above the 3 v even with ripple. \$\endgroup\$ – Short Circuit Aug 28 '17 at 16:42
  • \$\begingroup\$ I also removed IC U5 and check input (MODEM_TX), it has the ripple on it, so there is nothing related to LC resonant. Its just a non inverting buffer, output should follow the input except voltage level. \$\endgroup\$ – Short Circuit Aug 28 '17 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.