0
\$\begingroup\$

I'm a programmer who's been put in charge of some motor control problems and I need your help, apologies in advance for the very professional drawing.

Anyway, what i have is a PWM control board controlled by a 10K MCP-41X1 digital potentiometer with a 75 ohm wiper resistance. A mechanical 10K pot works fine (although the behavior is more on/off either/or 0 or 12V rather than continuously varying the speed, which is what I want to do) but the digital pot doesn't seem to have much effect at all -- in fact, at its lowest setting, the PWM output stays at 12V and doesn't drop at all.

enter image description here

Assuming that I verified that my setup was correct and that the digital pot/Arduino setup was operating properly, I would like some insight as to why the mechanical pot at least was able to turn the DMM reading down to 0V while the digital pot was not.

Any assistance in this matter is much appreciated in advance!

\$\endgroup\$
  • \$\begingroup\$ Have you tried adding a load to the voltage you're trying to measure? \$\endgroup\$ – Ignacio Vazquez-Abrams Aug 31 '17 at 16:51
  • \$\begingroup\$ If a standard pot gives you "more on/off than variable" control, I wouldn't say it works fine. I think you need more information on the control circuit -particularly how the input circuit really works, and what sort of control input it expects. \$\endgroup\$ – Peter Bennett Aug 31 '17 at 17:46
  • \$\begingroup\$ Just curious. But I see you have \$12\:\textrm{V}\$ PWM that is going to the motor, which means there exists a \$12\:\textrm{V}\$ supply rail. Are you sure that a \$5\:\textrm{V}\$ supply is applied to A, W, and B and also that the supply that is otherwise separately powering the MCP-41x1 also is \$5\:\textrm{V}\$? Just worried a little about A, W, and B exposed to voltages above \$V_{DD}\$. There is also leakage, but not enough that I'd imagine concerns: typical is \$100\:\textrm{nA}\$. Check voltages and also isolate the two systems and use an Ohmmeter to verify values while software runs. \$\endgroup\$ – jonk Aug 31 '17 at 18:50
  • \$\begingroup\$ The first step is to measure the wiper voltage. The wiper voltage should scale ratiometrically from 0 to 5V as you tune it digitally. \$\endgroup\$ – sstobbe Sep 1 '17 at 3:25
  • \$\begingroup\$ @Ignacio Vazquez-Abrams You got it. I foolishly forgot to connect any kind of load across the PWM terminals. Nevertheless, I hope this thread will help others who have encountered similar problems. \$\endgroup\$ – BasileSoftware Sep 1 '17 at 17:17
1
\$\begingroup\$

Ignacio Vazquez-Abrams had the right answer, I made the bonehead mistake of not connecting a load to the test setup. The test setup worked properly with the motor connected. I didn't try that right away because the rig belonged to somebody else and I wanted to proceed cautiously.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.