1
\$\begingroup\$

Recently I made an audio amplifier by following this video(https://www.youtube.com/watch?v=4ObzEft2R_g). The interesting thing is that when I plug the battery in, suddenly I received a very clear radio signal and the audio input acts like a antenna. Can anybody tell me what is going on here?enter image description here

\$\endgroup\$
  • \$\begingroup\$ By the way I used LM386 M-82. \$\endgroup\$ – shihao Chen Sep 4 '17 at 7:29
  • \$\begingroup\$ Electromagnetic interference and poor susceptibility. \$\endgroup\$ – Andy aka Sep 4 '17 at 7:46
2
\$\begingroup\$

It's normal, it happened also using a TBA820M.

The input wires (together with the traces going to the input of the LM386, and LM386's own input capacitance) form a parasitic antenna + resonant LC tuning circuit, which, by chance, has a resonant frequency very close to the station frequency you're listening to. These signals are amplified by 20 (accordingly to your schematics). The small non-linearity of the 386 might act as AM demodulator.

A small capacitor (e.g 6.8 nF) will kill the incoming RF signal, by forming a low-pass filter with the two 1-k Ohm resistors (while passing the full 20kHz audio signal. Actually, if you connect both signals, i.e. if you don't leave one channel open, the bandwidth will be 40kHz). For best effectiveness, put that capacitor (and the two 1-k resistors) close to the input of the LM386.

\$\endgroup\$
  • \$\begingroup\$ Outside the audio band, the LM386 non-linearity isn't small, and definitely capable of AM demodulation. \$\endgroup\$ – Brian Drummond Sep 4 '17 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.