4
\$\begingroup\$

My manufacturer is asking me to remove those lines from the ground gerber layer

enter image description here

The design was made in eagle, I've been searching information about this problem and I've found nothing, I don't know if it has a specific name or it isn't a real problem

It's a problem of the gerber file?

I'm using Eagle 8.3.0 and GERBER_RS274X as device output

Edit:

enter image description here

This is the same file exported to a pdf, I've visualized with microsoft edge at100% zoom. When zoom in into 300% the lines are gone

\$\endgroup\$
9
  • \$\begingroup\$ Did you try to export the file in PDF? Are the lines still here? \$\endgroup\$
    – M.Ferru
    Sep 12, 2017 at 15:39
  • \$\begingroup\$ It sounds like you need to change some "hatch" setup when rendering copper poor \$\endgroup\$ Sep 12, 2017 at 15:50
  • \$\begingroup\$ What version of Eagle? What version/type of Gerber? \$\endgroup\$ Sep 12, 2017 at 16:00
  • \$\begingroup\$ @M.Ferru I've printed the file and add the image in the post. \$\endgroup\$
    – GEPD
    Sep 12, 2017 at 16:01
  • \$\begingroup\$ @AliChen I've selected a solid polygon, but I've the "hatched", could be this be better than solid? \$\endgroup\$
    – GEPD
    Sep 12, 2017 at 16:02

2 Answers 2

2
\$\begingroup\$

I finally found a solution to this problem.

Well I don't know if I can really call this a solution because I had to switch software.

Before to switch I tried multiples cam files, I exported from Windows and Linux (Ubuntu). I started a topic in the autodesk forum. Some of the users were able to replicate my problem and others not. The Autodesk representatives were not interested in helping me, so I still don't know what is really happening. They answered but there is not a solution yet (01/2018) (see autodesk topic)

I must say that in Viewmate the problem wasn't present, but my manufacturer wasn't using that software, so wasn't a solution for me. Now with KiCAD the gerber files looks good in any platform or viewer.

My solution was download KiCAD, at this moment the last version is: 4.0.7, and import the brd file.

The steps to open the brd file are:

  1. open the pcbnew.exe file in the bin folder located in C:\Program Files\KiCad\ (I don't know how this works in the others platforms)

You have to do it that way, otherwise you won't have the open file option.

  1. Go to File > Open File and select XML PCB File from Eagle ver.6.x (*.brd)

When you select your file it will be imported in KiCAD. In my case I had to make the ground planes (zones) again, but I solved that in less than 5 minutes.

\$\endgroup\$
4
  • 1
    \$\begingroup\$ Might be worth trying an older version of Eagle (download page on Autodesk site). I use 6.6 and have never had such issues. It shouldn't have any major trouble opening newer versions of the .brd/.sch files (you get a note saying some parameter or other is undefined, but it doesn't affect the board/schematic). \$\endgroup\$ Sep 17, 2017 at 18:50
  • \$\begingroup\$ I forgot to mention, I've tried with version 6.0 and it happened same problem. I don't understand where is the problem and I know it can't be a bug affecting all users because no one is asking to fix that. But at least I saved the time spended doing the board, I'm also considerating change my manufacturer \$\endgroup\$
    – GEPD
    Sep 17, 2017 at 22:21
  • \$\begingroup\$ How odd. Could you upload the board file here and I'll have a try exporting it? \$\endgroup\$ Sep 18, 2017 at 6:52
  • \$\begingroup\$ I've using the esp32 sparkfun board: goo.gl/ZDJ8Qp the problem is easy to reproduce with gerbv. In ubuntu it was minor. But with KiCAD the preview was fine in all platform with any software \$\endgroup\$
    – GEPD
    Sep 18, 2017 at 15:05
1
\$\begingroup\$

Put a Width of 0 in the polygon properties.

screenshot

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.