1
\$\begingroup\$

I just bought a PICKit3 and Linux finds it:

$ lsusb
...

Bus 003 Device 081: ID 04d8:900a Microchip Technology, Inc. PICkit3

But MPLABX doesn't recognize it (see image, the SN-foldout is unavailable). I just re-installed v4.01 but the issue remains. I tried run MPLAB as root to see if it was a permission issue, but the error is for root as well.

I tried MPLABX under Windows, and it recognized the PICKit3 immediately. I am not, however, going to develop things under Windows.

Does the Linux-version of MPLABX require some special configuration? I am running 64-bit Debian 7.3 (according to /etc/debian_version).

enter image description here

\$\endgroup\$
12
  • \$\begingroup\$ I had no problems using it in Linux. I see that reinstalling doesn't help - so you might need to go to Microchip support. \$\endgroup\$
    – Reinderien
    Commented Sep 15, 2017 at 13:33
  • \$\begingroup\$ ..."I just re-installed v4.01 but the issue remains." \$\endgroup\$
    – bos
    Commented Sep 15, 2017 at 13:34
  • \$\begingroup\$ Yes, I saw that and edited my comment. \$\endgroup\$
    – Reinderien
    Commented Sep 15, 2017 at 13:35
  • 6
    \$\begingroup\$ Did you add the appropriate udev rules so that it can be accessed by user processes? \$\endgroup\$ Commented Sep 15, 2017 at 16:22
  • 1
    \$\begingroup\$ No rebooting required. You can reload the rules with udevadm: "udevadm control --reload" \$\endgroup\$
    – Ayhan
    Commented Sep 15, 2017 at 20:21

2 Answers 2

1
\$\begingroup\$

The problem was that I was using a too old glibc-version for the MPLABCOMM-libs. Upgrading the glibc solved everything.

\$\endgroup\$
2
  • \$\begingroup\$ wow, im really surprised that you got it working under Linux. Did you buy the XC8 compiler for linux as well? \$\endgroup\$
    – Abel Tom
    Commented Jul 12, 2018 at 5:07
  • 1
    \$\begingroup\$ No, I use the free version. \$\endgroup\$
    – bos
    Commented Jul 12, 2018 at 13:20
1
\$\begingroup\$

Recently I updated glibc-xxx, but the problem still persists. Now i'm trying with this way, from microchipdeveloper.com mplabx:installation#step9

For Linux distributions that use systemd, the systemd-udevd unit may be setup to avoid inter-process communications via sockets for security reasons. Recently Ubuntu 18.04LTS has been shipped in this way. This is a change from 17.10. Other distributions like Manjaro are also shipped with blocked inter--process communications via systemd. MPLAB X IPE and IDE rely on the systemd--udevd unit for plug and play. MPLAB X software has udev rules that allow a program to run on plug-and-play notifications. This program relies on sockets to communicate with MPLAB X IDE and IPE. So, to have working plug-and-play in MPLAB X software, you need to re-enable socket communications.

You can do this by adding an override file for systemd-udevd. ​

$ sudo systemctl edit systemd-udevd

This will open an editor and will create an override.conf file. In the override file, include the following lines: ​

[Service]

IPAddressAllow=localhost

Then re-start the service: ​

$ sudo systemctl daemon-reload

Finally check the override.conf has been loaded: ​

$ sudo systemctl status systemd-udevd

● systemd-udevd.service - udev Kernel Device Manager
Loaded: loaded (/lib/systemd/system/systemd-udevd.service; static; vendor preset: enabled)
Drop-In: /etc/systemd/system/systemd-udevd.service.d
           └─override.conf

IN MY CASE :

systemd-udevd.service - udev Kernel Device Manager   
> Loaded: loaded (/usr/lib/systemd/system/systemd-udevd.service; static;
> vendor preset: disabled)
jul 11 22:00:53 localhost.localdomain systemd-udevd[2757]: Process
> '/etc/.mplab_ide/mchplinusbdevice add' failed with exit code 250.
\$\endgroup\$
2
  • \$\begingroup\$ Hi - Thanks for this info. It's not clear to me exactly what you mean by "Now i'm trying whint this way". At the end of the text you copied from microchipdeveloper.com/mplabx:installation#step9 (some of which is unfortunately incomplete and needs fixing) you seem to be reporting an error message. So my questions are: (a) Have you actually successfully followed those steps and this is an answer? (In which case, why are you reporting an error?) Or do you have problems, and this is a question that's in the wrong place? (b) Will you be fixing the problems with the copied text? \$\endgroup\$
    – SamGibson
    Commented Jul 12, 2018 at 3:56
  • \$\begingroup\$ Hi, (a) The PICKIT3 is completely functional following those steps. (b) the reporting error message still persist, but not seem affect the pickit3 functions. \$\endgroup\$ Commented Jul 13, 2018 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.