0
\$\begingroup\$

I am designing an RF PCB in Altium and I have set rules for 75 ohm as well as 50 ohm impedance traces. The picture attached shows a particular 75 ohm traces with error markers. The trace width is as specified by the rule and the DRC check does not show any errors. When I reset the error markers the markers do not go away. As you can see the traces are not the problem since the markers are also showing up on component pads.

I appreciate any comments.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Right click on the trace with errors. On the pop-up menu, scroll down to the "Violations..." item. Hover on that (or click it?) and see which rule is being violated. If it's still not obvious what the problem is, edit your question with the information about the rule being violated. \$\endgroup\$ – The Photon Sep 25 '17 at 3:46
  • \$\begingroup\$ This is the issue, it shows no violations. Just markers. I am baffled. \$\endgroup\$ – Nima Nikvand Sep 25 '17 at 23:15
0
\$\begingroup\$

Are you sure it's a violation marker? Those default to bright green. What you have could just be display override color for that net's connections.

Is the * column for the net checked in the PCB control pane, like this one?

enter image description here

Un-check your net and it should then only color ratsnest wires and not all objects tied to that net.

Edit: clicking around a bit more it looks like this feature is called "display override" in case you want to search for it on the Altium Wiki.

|improve this answer|||||
\$\endgroup\$
0
\$\begingroup\$

If you are defining a particular rule for these primitives that go against global rules (eg. track width), these errors will actually remain highlighted unless you uncheck the "Online DRC" option.

|improve this answer|||||
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.