1
\$\begingroup\$

I am trying to communicate with SIM7100 GSM modem but I could just rarely communicate with it across UART interface. I am observing the signal with an oscilloscope, I am giving 5V as High and 0V as Low, 8 data bit,1 start and 1 stop bit with a baud rate of 115200, at my DTE. Signals are passing thru RS232 Line Driver and a Level Shifter, then arrive to the DCE (GSM modem) with a corrected and inverted signal, which is 1.8V as High and 0V as Low (I have also tried to send for just being sure the inverse of the signal, or reverse of the bit order but GSM modem did not give any response).

When I send the AT command, it sometimes return just echo AT, sometimes OK and sometimes Booting, etc. responses. But most of the time it returns nothing. Since I use the National Instruments VISA terminal for serial communication, I am sure that the send signal is correct and reading is also proper.

If it did not give any response, I could consider it as there is a mistake with the hardware, but the seldom given responses makes me thing my hardware connection is correct (Indeed, I used only the reference designs).

I manually measured all the voltage levels, and the signals at all of the pins including GSM and RS232 for both DCE and DTE. They were all correct, except TxD line sourcing from GSM modem to the microcontroller, which is always asserted. I have also tried 4 different SIM7100 GSM modems if there were a problem with the modem.

Now, no AT or OK receives to me, but sometimes I receive

1: Read Operation Return Count: 2 bytes \00\00

2: Read Operation Return Count: 12 bytes Booting...\r\n

3: Read Operation Return Count: 2 bytes \r\n

4: Read Operation Return Count: 10 bytes SMS\sDONE\r\n

5: Read Operation Return Count: 2 bytes \r\n

6: Read Operation Return Count: 9 bytes PB\sDONE\r\n

What could be the problem?


This first picture set is about my circuit design.

enter image description here

enter image description here


This second picture set is about the GSM RxD signal levels (required and observed). I checked also the datasheets related sections again and I could not find any conflict. UART Pin Logic Level_SIM7100_Hardware Design_V1.01_p.33_2014-09-10

GSM_RxD_Oscilloscope Shot

I want to edit the question for new response data.

I am now taking this response whatever I do. What does is mean? What could I do to communicate with GSM this modem?

1: Read Operation
Return Count: 39 bytes
\D8\00!\17-#1\A3\A3\A3\E5\EB\00\00y\00\00e\00wacu\E5\EB\00\00y\
BD\B5\00wacu\E5\EB\00\00

PeterJ told me "set your scope to trigger if the voltage to the module drops below 3.4V briefly" about this edit. I will try this.

Is there any other suggestion?

\$\endgroup\$
  • \$\begingroup\$ 1.8V as High and 0V as Low huh.. that's not RS232...... Got a schematic of that part? \$\endgroup\$ – Trevor_G Sep 26 '17 at 14:09
  • \$\begingroup\$ @Trevor I think the OP wants to convert RS232 to a logic level accepted by the modem. Though it is unclear how. \$\endgroup\$ – Bence Kaulics Sep 26 '17 at 14:12
  • \$\begingroup\$ @BenceKaulics maybe, but then why use an RS232 driver... \$\endgroup\$ – Trevor_G Sep 26 '17 at 14:13
  • 2
    \$\begingroup\$ You should really post a schematic and layout of your circuit. This sort of thing sounds like a power supply problem - a lot of GSM modules will do odd things if the power supply dips for even microseconds and they have high but short peak current demands. \$\endgroup\$ – PeterJ Sep 26 '17 at 14:19
  • \$\begingroup\$ Yes I know about +12 and -12V, but GSM modem datasheet tells that levels for high and low state. I used line driver because the microcontroller digital output is ttl and gives 5 and 0 volts for those levels, and recommends to use ti rs232 line driver. A TI level shifter is recommended by GSM modem, to convert the +12 and -12 volts to 1.8 and 0 volts. Yes I see I should post the corresponding refereces, thank you for your advance \$\endgroup\$ – onrep Sep 26 '17 at 15:30
2
\$\begingroup\$

I have found the problem, and may now give the answer to my own question. The optocoupler is broken, hence I removed it and Voila!

\$\endgroup\$
  • 1
    \$\begingroup\$ Not sure if I'm missing something but your schematic doesn't seem to include an optocoupler, do you mean one of the level translators? \$\endgroup\$ – PeterJ Oct 2 '17 at 10:46
1
\$\begingroup\$

I believe I am having the same problem today... Can you confirm that you did or did not remove the Voltage Translator...

I have this unit that I ordered from Amazon... my unit is actually a version 2.2 sold by DIYmall

enter image description here

I believe the voltage translator you are referring to...is the TXB0108 by Texas Instruments... circled in red...

There is a microusb port, labeled "DEBUG" on the unit... I tried that port ... after installing the windows drivers and connecting to COM Port 14... and I was able to send an SMS message via Python, so I can confirm that module...with the SIM card works... but the UART...is just dead in my opinion.

But if anyone has any ideas on getting it working via the UART... I'm all ears...

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.