0
\$\begingroup\$

I'm trying to use a www.sparkfun.com/products/13879 with one 3 wires load cell I gathered from an old scale, so I reproduced this schematic. However the reading is always the same. I use the code from a learn.sparkfun.com/tutorials/load-cell-amplifier-hx711-breakout-hookup-guide#arduino-code BUT I do use read() (raw value from the HX711 instead of the user friendly and calibred value).

So I looked at the resistance of each wire (I have the red,black,white wires patterns) and sure it look like the pattern is right (black-red is 1k, black-white is 2k, red to black is 1k).

I looked at my wire, try to redo my wire and the result was the same. So maybe the load cell is broken.

So I tried to use a potentiometer instead (which also have the benefit to be more controlable), so I reproduced this schematic instead and same result, I always have the same value (8388607). (For each +Active I use a different potentiometer where the middle pin is the output (A- and A+); I tried to connect the potentiometer gnd to GND and try to let them unconnected.

I tried to unconnect the data lines from the HX711 and the value is a negative one meaning the chip should somehow work.

What can I look for or what could I try as a simpler test?

Thanks

\$\endgroup\$
  • \$\begingroup\$ I talked with the customer service and they send me a new unit which fixed my issues. As an additional note from the richdyer2000 I used load from an existing scale and connecting wire with a breadboard (so no soldering was needed). \$\endgroup\$ – 0xCDCDCDCD Dec 10 '17 at 16:09
1
\$\begingroup\$

I had the exact same problem upto an hour ago.

I’m using SparkFun’s load cell combinator circuit diagram here...

https://cdn.sparkfun.com/datasheets/Sensors/ForceFlex/SparkFun%20Load%20Sensor%20Combinator%20v11.pdf

...and identified +/-/c on each sensor independently of colour (ca 2kohms between + & -, 1 kohm and dropping with strain between c & +). I had been using screw connectors to make changes easy, especially due to the ambiguity caused by non standard wire colours for each sensor. Obviously at least one connection wasn’t good enough with the screw connectors: It didn’t work after rewiring from scratch several times even with completely different hardware. As soon as i soldered all connections within the Wheatstone bridge and into the load cell amp, it worked fine. After months of frustration, I’ve built 2 scales in the last hour!

Jump leads are fine from the loadcell amp to your arduino/rpi

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.