3
\$\begingroup\$

this issue arises out of no where periodically. Very frustrated!!

Suddenly I am unable to select any component on the PCB board in order to move it/right-click (the grey box doesn't appear).

I have tried selecting a box around the component but it does not highlight it. I cannot even right click to see properties. It is as if the component is gone

I can however, with 'cross select mode' in tools enabled, select the component in the schematic, come back into my pcb design and click 'reposition selected components', however once the component is placed i cannot then click back onto it to adjust or do anything.

After it happens i close it down, go back to an earlier save that i know was working fine, and the problem persists.

Can anybody think of any reason why it would do this??

maybe i have clicked a keyboard shortcut by accident?

\$\endgroup\$
  • 1
    \$\begingroup\$ Maybe you accidentally set the "locked" property to true? \$\endgroup\$ – Rev1.0 Oct 4 '17 at 13:54
  • \$\begingroup\$ Thanks, do you know how this could have been done? \$\endgroup\$ – Terry Goodman Oct 4 '17 at 16:10
  • \$\begingroup\$ I have used 'Edit>Select>All locked' but nothing is selected. Even when I use 'Edit>Select>All on Layer' which should work as far as I know, but still no components are selected. \$\endgroup\$ – Terry Goodman Oct 4 '17 at 16:14
  • \$\begingroup\$ Also, when I go into the internal plane layer, I should be able to double click and bring up the options of which signal i want the plane, but no options appear, seems to be connected to the same issue. Spending many hours trying to resolve this with no luck... any help much appreciated! \$\endgroup\$ – Terry Goodman Oct 5 '17 at 16:29
  • \$\begingroup\$ Maybe you somehow re-assigned the left mouse key or something weird like that? Can you move a component when you select it using the side panel and then use the arrow keys? \$\endgroup\$ – Rev1.0 Oct 5 '17 at 18:34
3
\$\begingroup\$

You must make sure that the Components (or All Objects) object is selected inside the Properties panel in the PCB editor. You cannot use the mouse to click and select objects in the editor that are deselected in the selection filter. It's a feature you'll probably want to keep pinned to the sidebar.

\$\endgroup\$
3
\$\begingroup\$

Nearly lost my mind over this myself...

Check selection filter in properties tab! In Altium 18 this is after the search field

\$\endgroup\$
1
\$\begingroup\$

If you click the clear button you should be able to select again. I had it also a few times.

\$\endgroup\$
0
\$\begingroup\$

Even after checking the selection filter(s), I was unable to select a polygon (also, the polygon manager said the polygon was not modified, and not locked). I needed to right-click->Polygon Manager & then click Repour...->Force Repour All Polygons, which seemed to make the polygon selectable again.

\$\endgroup\$
0
\$\begingroup\$

Yes this is very frustrating. There is a deep bug in Altium. Some times it helps to set all components to locked, and then back to unlocked. But last time the solution was to select all components. Then move them a bit, and then selecting undo so all moved back to their original position. After this, all components could be selected as usual.

The chalenge is of cause to select the components when they can not be selected. For me the select touching rectangle (drag left) was working, even if the selection was not highlighted.

Retrying this on another version of the same pcb, with the same problem did not work. I have even tried Altium 19 and 17 without any success.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.