I'm finishing one of my pcb layout, in this case is a multilayer one. the trouble is that design rule checker find me 5 unconnected GND pads but the trouble is that this pads are close to a copper ground polygon (connected to ground) but it does not connect to pour. If i try to add a net manually when it repour the ground polygon it delete this new connection. this is an error!

here my screenshot:

enter image description here

as you can see, in the bottom of the page ther are the design rule checker outputs. and on the center of the screen there's a GND pad unconnected to the close gnd copper fill.

How can i solve this trouble?


  • 1
    \$\begingroup\$ What options have you selected for the poly pour? Specifically have you selected "pour over all same net objects"? \$\endgroup\$ – Spehro Pefhany Oct 11 '17 at 22:50

It looks like you have the polygon connect style set to relief connection at 45 degree angles. But this pad doesn't have enough clearance around it at the corners to make a connection at 45 degree angles.

Try changing the relief style in design rules, under the "Plane" cateory, to relief connection at 90 degree angle.

If you don't want to affect the rest of your design, you can make a new rule for this named polygon only, to change its relief style.

enter image description here

| improve this answer | |
  • \$\begingroup\$ Right on, this is exactly what I was going to say. \$\endgroup\$ – DerStrom8 Oct 11 '17 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.