0
\$\begingroup\$

I have wired up my potentiometer to my breadboard with an LED and motor, and it only works intermittently. When I twist it certain ways it works, and other ways it doesn't.

I removed the wires, removed all the solder, and tried testing with my multimeter. If I check resistance on the terminals (positive to center, negative to either side, as well as positve and negative on opposite sides), i get infinite resistance. If I test directly on the resistive element after taking it apart and I read 0-46.K Ohms.

I examine the terminals and I don't notice anything wrong... so what gives? Should I even bother wasting my time trying to fix this as a newbie or buy a new one?

It has a W.L B50K on it.

EDIT: Sorry I should have said I first tested with resistance setting on multimeter. I got infinite resistance when testing the terminals. If I tested directly on the resistive element track I would get 0-about 45.6KOhms.

Here are pictures

enter image description here enter image description here

\$\endgroup\$
  • \$\begingroup\$ Sounds broken to me, but theres not much we can do without pictures and/or part numbers \$\endgroup\$ – BeB00 Oct 13 '17 at 0:02
  • \$\begingroup\$ "If I check continuity on the terminals" Don't check potentiometers using a continuity range - use an appropriate resistance range on your multimeter. It might help readers to better understand the situation if you supply the actual resistance readings end-to-end (should be a fixed value) and between each end and the wiper (which should increase monotonically measured between one track end & the wiper, and decrease similarly between the other track end & the wiper, as the wiper is turned from one track end to the other). \$\endgroup\$ – SamGibson Oct 13 '17 at 0:08
  • \$\begingroup\$ Yes, sorry. I did check resistance first, but I kept getting infinite resistance when using the terminals. \$\endgroup\$ – Cowman Oct 13 '17 at 0:14
  • \$\begingroup\$ "I kept getting infinite resistance when using the terminals." It's still not clear which terminals you were measuring, which makes a difference for understanding the specific problem :-( I don't think I could have been clearer about the numbers that I wanted to see, so I'm going to stop here as there is some kind of communications problem. Hopefully someone else who understands the story better, will help you further. Good luck! \$\endgroup\$ – SamGibson Oct 13 '17 at 0:31
  • \$\begingroup\$ I've done all of them. Positive lead in middle terminal, negative on left side. Positive lead in middle terminal, negative on right side. Positive lead on one side, negative lead on other side no lead in middle. I got infinite ohms each and every time, no matter where wiper was positioned. I've verified multimeter works. \$\endgroup\$ – Cowman Oct 13 '17 at 0:36
1
\$\begingroup\$

I solved this issue myself by taking needle-nose pliers and applying more pressure to where the terminals connect to the track.

They looked fine before, and looked no different after applying pressure, but it works now consistently.

\$\endgroup\$
  • \$\begingroup\$ Excellent news, well done (+1) I was just thinking about the same concern, that perhaps the soldering had affected the press contact between the metal terminals & the track (notice in the top photo, how solder has definitely got into that area on the centre terminal - I can't be sure on the others. This may have affected the long-term reliability of this potentiometer). You'll be able to accept your own answer in 48 hours (I think that's the site's delay time for self-accepting). \$\endgroup\$ – SamGibson Oct 13 '17 at 1:20
  • \$\begingroup\$ Maybe you could have communicated that then... but it seems we were speaking completely different languages. And yeah thanks I know... been a member for over 5 years on this account and since 2009 overall. Sorry to be salty, but i have little patience for people with such little patience and understanding. Stack overflow is infested with people with big scores and little patience. \$\endgroup\$ – Cowman Oct 13 '17 at 1:28
  • \$\begingroup\$ "Maybe you could have communicated that then" - I only figured it out as a possible explanation, after re-reading the whole thread several times. It's not like I was withholding! The earlier details about the continuity tests really threw me, and it's not always possible to "undo" a train of thought quickly. I was literally about to start typing that hypothesis, and noticed your answer appear :-) Glad you got there in the end :-) Just FYI personally I wouldn't trust that potentiometer for anything important, once that connection(s) to the resistive track has been compromised. Good luck! \$\endgroup\$ – SamGibson Oct 13 '17 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.