5
\$\begingroup\$

I am setting up my XBee radio using the official X-CTU tool. The XBee is connected to a USB XBee explorer. The first time I did it was a few weeks ago, and I kept getting errors (see below), but however not constantly. Today, I have not been able to make a single piece of communication with the modem without needing a reset.

I open X-CTU, pick the correct COM-port, and click "Test / Query". I get this error message:

Action required. Unable to communicate with modem.

I then reset the XBee by short-wiring pin 5 and 10 (my Arduino does not have a reset button). Instantly the error message disappears, and I get the expected result.

Communication with modem..Ok

If I click Retry, I get the first error message again. Every time, out of at least ten trials, the error message appeared after clicking Retry, and every time, the correct infobox appears after resetting by short-wiring.

Is my XBee simply broken, or what is going on here?

\$\endgroup\$
3
\$\begingroup\$

Have you checked if your Baud Rate in X-CTU match the Xbee module Baud Rate? This is probably the cause.

Also your Xbee module might not be making contact with the board.

\$\endgroup\$
  • \$\begingroup\$ This. I've had the exact same problem the OP is having, and it was because X-CTU was trying to communicate with the wrong baud-rate. When you reset the Xbee, the bootloader initially tries to talk at a fixed baud-rate, and if it doesn't hear anything, it loads the user configuration. If your configuration changes the baud-rate, it will then loose contact with the PC. \$\endgroup\$ – Connor Wolf Dec 24 '12 at 5:14
2
\$\begingroup\$

This may or may not be the same problem, but I have seen a similar problem when the XBee module is receiving data from another XBee module while I'm trying to contact it through X-CTU. X-CTU seems to get confused because of the stream of data arriving from the other XBee(s) and isn't able to talk to the module for some reason.

My solution is to go into the Terminal tab, click in the ASCII portion of the Terminal, type +++ (you should see an OK response), then quickly do whatever I want to do in X-CTU before command mode times out. Although it's annoying to do, it works every time for me.

\$\endgroup\$
0
\$\begingroup\$

There's not much info to work on but I can tell you that I had a similar problem when I started working on xBee.

The thing I was missing was that once the device is setup for cyclic sleep it doesn't respond to serial communications for the entire time it's sleeping. This means that if you set it up for being awake for just 100 ms it is very likely that you'll have to reset it every time you want to modify a parameter.

\$\endgroup\$
0
\$\begingroup\$

My solution to this, was just selecting the right firmware and writing it to the xbee. Go to Modem Configuration. Select the right firmware (XBP09-DM for me). Press Write. (Now you get the cannot connect message, so you reset it) Uploads the firmware. Done! Every single connection from now on, is successful.

\$\endgroup\$
0
\$\begingroup\$

Im a rookie and quite new to XBees and Wireless communications.

But let me tell you something,

I had the same exact problem with my XBee S2, Few days back it was working fine in AT Mode, I configured it to be an End Device .

for the past 2 days when i was trying to reconfigure my XBee , i was thrown up with the same ACTION REQUIRED window repeatedly and once in a while i was able to communicate with the XBee , that too didn't last long because of connection time out.

THAT WAS FRIGHTENING ME , like i told myself that i bricked the module , but later on , i tried looking into Digi troubleshooting forums. I came across the statement saying that

END DEVICES sleep often :/

and i had to force start the boot loader in order to establish stable connection to make any further changes , for my XBee S2 , i had to change my baud rate to 115200 , which is the Bootloader Baud rate or something , and i went ahead to the terminal to check DTR and Break , and Unchecked RTS.

Now i reset the board and went back to terminal to uncheck Break.

Takes some time , but the XBee gets ready to be restored and flashed with a new firmware :)

Let me know if this helps (i know its 2 years since the original post , I'm just sharing this here, in case if someone has the same issue in the future , they can rectify it)

a proper recovery guide is given here http://www.digi.com/support/kbase/kbaseresultdetl?id=3402

Peace out :)

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.