0
\$\begingroup\$

I placed a device and package on the schematic and board. However, the package appears different on the pcb, and generates DRC 'dimension' errors. The package is a 3-pin sip, Allegro Micro Hall-effect bipolar switch. The difference is the pads are much larger when the package appears on the brd screen in Eagle Cad, which doesn't leave enough space between pads. I have been using Eagle Cad for a few years. Unfortunately, its only about once a year, so I hope the solution is obvious to some of you experts out there. The drag and drop option for pictures didn't work, otherwise, I would have done included the pictures.

\$\endgroup\$
  • \$\begingroup\$ A picture say more than 1000 words, and a link to the .lbr would be nice. \$\endgroup\$ – MatsK Oct 13 '17 at 18:43
1
\$\begingroup\$

After a couple of days off and on of searching, I finally found that the problem was a circular board defined with 0 width on the dimension layer. Eagle apparently fills in the circle if 0 width. Changed it to smallest value and everything is okay as far as DRC. But package still appears different from what is in the package editor (not in the library, as mentioned before). Right clicking and selecting 'open package' has a package with ~20mils between pads, where the part on the brd has about 8mils.

The part is in the Allegro.lbr library.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.