1
\$\begingroup\$

I'm starting to simulate a complicated schematic in Altium which looks in LTSpice like this:

enter image description here

In Altium I can split this scheme into several sheets to make it more convinient to work.

So I make part of the scheme (generator.SchDoc):

enter image description here

And a simple root document (top.SchDoc):

enter image description here

So I assumed that this should work fine. However, simulation works well if I press the "Run active simulation" button in the Generator sheet. If I do this while I'm in the Top.SchDoc - the simulation result is a horisontal line (dispite that I have netC1_2 net displayed in both cases).

Looks like Altium did not figured out the ierarchy right.

How do I fix that out?

\$\endgroup\$
7
  • 2
    \$\begingroup\$ Simulation in Altium is an afterthought and not well supported. Better solution is to learn how to make subcircuits in LTSpice. \$\endgroup\$
    – The Photon
    Oct 14 '17 at 18:27
  • 1
    \$\begingroup\$ @ThePhoton the goal was not to split the model into several sheet. I intended to use Altium as all-in-one software to reduce error probabillity. I heard that LTSpice has the ability to use multi-sheet design. So you think that using Altium for simulation is a bad idea?! \$\endgroup\$ Oct 14 '17 at 18:48
  • 1
    \$\begingroup\$ I think using altium for simulation is a bad idea \$\endgroup\$
    – Voltage Spike
    Oct 17 '17 at 16:35
  • \$\begingroup\$ Almost everyone thinks that using Altium for simulation is a bad idea. Except for Altium's sales department. Use a dedicated simulator for simulations, keep pcb software for pcb's, and you will be much happier. \$\endgroup\$ Oct 17 '17 at 18:22
  • \$\begingroup\$ Simulation is definitely not a main focus of Altium, and Altium is not a good candidate for an all-in-one software package. Altium's main focus is schematic and PCB design. Mechanical drawings and simulation are afterthoughts and, while they may work to an extend, they are not well-supported. If you must have an all-in-one package you could try Proteus, though I never cared for its PCB design environment \$\endgroup\$
    – DerStrom8
    Oct 18 '17 at 1:45
1
+200
\$\begingroup\$

Probable solution: Project-Options setup for nets. Especially the GND net. Probably SIM does not like nets with multiple net names. Configure net inheritance as shown (way) below. Check the compiler messages and fix everything before running sims.

Simulation ground configuration, or setup error. In other words, it works for me. See below.

Every page needs a ground symbol, connected to your ground circuit

Sometimes when a power port is routed through a sheet entry, it is demoted to a local net. Perhaps this is confusing the sim compiler. Forego routing power ports through sheet entries, and just use the power ports as global on each sheet, as shown in my sample below.

The ground net name is also important, in my case it's "GND", and is settable in the "Spice Reference Net Name" text entry in "Analyses Setup (Mixed Sim)" window.

Also, make sure everything compiles with no errors.

Altium does sims.

In addition, are your "value" parameters setup properly for each component? You may need to look in each of your sim models to confirm what parameters you are expected to provide.

Altium simulator is best simulator

Something more like what you are doing (edit):

Altium simulates you.

MORE!! edits

So, I got it to work with only 1 GND, with your same structure. Go figure. Must be some detail wrong with your circuit.

enter image description here


After looking at a downloaded copy of your project:

Running Project->Compile PCB Project, the messages window reports that the GND net had multiple net names. The resolution to this is to set the Project Options such that Power Port names take priority. See pic below.

After that change, everything worked (or at least I see sim results).

Also, Altium Pet Peeve: I would suggest that you consider the grid units in SCH to be unitless, and leave the grid spacing in SCH to the default of 10. This will prevent components and pins (especially ones from the default libraries) from ending up off grid.

enter image description here

A copy of the project can be found here: https://www.dropbox.com/s/kcyl91chh2aid6o/20170907_CK-mods.zip?dl=0

Output: enter image description here -Chris

\$\endgroup\$
2
  • \$\begingroup\$ Chris, thank you for your input! I need a day or so to figure out all the things you've said. I'll come back to the answer soon! \$\endgroup\$ Oct 18 '17 at 20:10
  • \$\begingroup\$ I got it to work. See updates above. \$\endgroup\$ Oct 19 '17 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.