2
\$\begingroup\$

I got an Altium question. I'm trying to speed up my Altium workflow.

Everytime I Design > Update Schematics, when I import all the footprints into the .PcbDoc the part designator overlay text is way too big.

Usually I go through PCB Filter > PCB List and manually set the text size for the designators by hand.

That's getting old, and I'm getting better at Altium. Time to take it to the next level!

Where is that default text size parameters coming from? How can I just have the part designator text be the size I want whenever I update a schematic?

Thanks!

\$\endgroup\$
1
\$\begingroup\$

Go to DXP > Preferences > PCB Editor > Defaults and select Component from the list of primitives. Click the Edit Values button and change the designator properties as required.

Preferences

\$\endgroup\$
4
\$\begingroup\$

In case anyone else found this question, there is a slight change with Altium 18. The Designator now has its own menu:

enter image description here

EDIT: Here is an example of 0.025" text height and 0.005" width silkscreen on a PCB next to some actual components. The resistors are 0603 and the caps are 0402.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Unrelated, but have you had good luck with 0.127mm (0.005") stroke width designators? \$\endgroup\$ – Spehro Pefhany Jul 6 '18 at 16:58
  • 1
    \$\begingroup\$ Yes, they are actually quite legible. I can say for sure that Advanced circuits is capable of the 0.005" width using their standard process on their 33 or 66 each boards. See my edit above as an example! \$\endgroup\$ – FullmetalEngineer Jul 9 '18 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.