1
\$\begingroup\$

I'm creating a custom documentation template and my project title always shows up in red italic font:

enter image description here

Is there a way to change the font?

Also the sheet numbering shows up as "Sheet 1 * of 1" even though my Sheet Parameter is set to "1". Can I change it to show the number only? I verified the number does not contain any asterisks:

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ It's best on this site to split off second question about numbering into a separate question. \$\endgroup\$ Oct 23, 2017 at 18:42

4 Answers 4

1
\$\begingroup\$

You need to edit the SchDot (schematic document template) file if you want to change the font. If you are using a default template you should be able to find it in C:\Users\Public\Documents\Altium\[Version]\Templates.

How do you set your page number text? If the SchDot is set up correctly you should be able to add your page number by using the Design -> Document Options -> Parameters dialog. My guess is there's an asterisk either hard-written into your template (unlikely) or you're setting your document number incorrectly and the asterisk is the default found in the location I just mentioned (Document Options -> Parameters). You should be able to clear it out from there.

Without giving us more information of how you have your template set up, this is about the best I can do to solve the problem.

\$\endgroup\$
4
  • \$\begingroup\$ I copied existing template and started modifying the parameters but what I'm asking is how can I change the font in the template? I can't find any relevant setting in Document Options for that. As for the numbering - I verified there are no asterisks in my Parameters - attached a screenshot to first post. \$\endgroup\$
    – pavel
    Oct 24, 2017 at 8:13
  • \$\begingroup\$ In the template you simply double-click the text whose font you want to change and select the font from the properties window that appears. \$\endgroup\$
    – DerStrom8
    Oct 24, 2017 at 11:44
  • \$\begingroup\$ Problem was I couldn't find anything to click on, because my Title field was empty instead of having an asterisks, so I didn't see the text. \$\endgroup\$
    – pavel
    Nov 6, 2017 at 14:43
  • \$\begingroup\$ Ah right, you'd need to enter something in the title field first. I failed to mention that \$\endgroup\$
    – DerStrom8
    Nov 6, 2017 at 19:45
0
\$\begingroup\$

Not sure how to edit the font that you are seeing, but here's one thing worth a try.

Go to Document Options > Sheet Options > Change System Font, set your preferences and maybe you could reset your red Italic font from there.

Again, not sure how to individually change the font of each individual entry, and not sure why it would be needed.

\$\endgroup\$
0
\$\begingroup\$

Regarding the title font - my Title field was empty and so I never saw the displayed text. Putting in an asterisks (or any symbol) as a Title, which should be the default anyway, makes the text appear (duh) and it's just editing the string from there.

\$\endgroup\$
0
\$\begingroup\$

1.you have to change schematic document template, to edit letter font.

2.C:\Users\Public\Documents\Altium\AD16\Templates.Here select and open the "schematic document template file".

3."Double-click" on the word in which you need to change the font and an annotation dialogue box will appear as given in the attached image where there an option to change the font. enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.