2
\$\begingroup\$

So basically I'm trying to make a circuit for a piezo-electric actuator. I only have access to a single supply at +70V for my op amp, an OPA445AP. Vin varies between 0 and +3V. I've looked at the help given by TI in this PDF and have come up with the following circuit. I've implemented it but when I power it up, Vout saturates at around +68V regardless of Vin. When I've simulated the circuit it indicates that it should work as expected.

Have I messed something with my circuit design up or is the OPA445AP not suitable for use with a single supply? Thanks in advance for your help.

Matt

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • \$\begingroup\$ Is there a reason you're biasing the input so heavily? What is the input supposed to be? \$\endgroup\$ – ThreePhaseEel Oct 28 '17 at 23:07
  • \$\begingroup\$ Do you mean Vref? I basically followed the equations and instructions given in the pdf to try and get my desired output. My input will (eventually) be given by a raspberry pi dac/adc, currently I'm just using a DC signal generator. I'm looking for a gain of around 20 so from an input of 0-3V I would to get up to around 60V. \$\endgroup\$ – user167210 Oct 28 '17 at 23:18
3
\$\begingroup\$

enter image description here

Figure 1. From the OPA445 datasheet page 2.

This is telling you that the inputs don't work within 3 V of the supply rails.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ So I need to lower my input biasing voltage? Or increase Vin so it's more than 3V above ground? \$\endgroup\$ – user167210 Oct 28 '17 at 23:23
  • \$\begingroup\$ Or create a negative voltage rail more than 3 V negative. R2 is only pulling up by about 1/270. At 0 V in your + input is only 70/270 = 0.25 V. \$\endgroup\$ – Transistor Oct 28 '17 at 23:29
  • \$\begingroup\$ Ok, I'll see what I can do, if it works I'll accept this. Thanks for your help. \$\endgroup\$ – user167210 Oct 28 '17 at 23:37
  • \$\begingroup\$ Wait for the Earth to spin once before accepting my answer. That gives everyone who's asleep now a chance. You might get a better answer. \$\endgroup\$ – Transistor Oct 28 '17 at 23:42
3
\$\begingroup\$

Many piezo amplifier circuits need a first stage amplifier to get around the requirements of the final output stage amp. However, this will also probably require some sort of negative rail in the final implementation.

What about a different amplifier? LT makes a great CMOS high voltage amp with rail to rail outputs (and inputs) that you might be able to dead-bug modify into your circuit, albeit with poor thermal dissipation:

http://cds.linear.com/docs/en/datasheet/6090fe.pdf

LTC6090 is the part number. 0 - 150V total supply, picoamp input bias current (would get around your heavy input bias vref circuit also). Here's the Digi-key link:

https://www.digikey.com/product-detail/en/linear-technology/LTC6090CS8E-5-PBF/LTC6090CS8E-5-PBF-ND/4864140

|improve this answer|||||
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.