1
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

I declare I'm kinda noob in electronics, but I know the most basics and I wanted to take some measurements so I could get used to them in practice.

The setup:
4xAA alkaline batteries in series with little use and measured at about 6V (so definitely not dead).
Battery positive to multimeter to 1Kohm resistance to LED to battery negative.
Multimeter (DT9205A+) black cable connected to COM and the red to mA and the switch pointing to DC current (tested all values).

When the circuit closes, the LED lights up and the multimeter shows 1 on the left (that is overflow indication). That happens with every scale of the DC current measuring setting. When the red cable goes to the greater current input (up to 20A), it displays 0, but that means it's just too small a value to display anything. I've tested with other setups and the large scale input seems to be working properly.

Since the mA input says it's fused and I'm a noob, I would expect to have somehow burn the fuse. But the circuit closes (the LED lights up) and I've also opened the multimeter and seen the fuse to be ok.

Any suggestion as to what could be wrong (either with my multimeter, or my setup) would be much appreciated!

\$\endgroup\$
  • 4
    \$\begingroup\$ a schematic says more than a thousand words. Please use the built-in schematics editor to clarify how your measurement setup looks like – as is, I'm rather confused, but the way you measure is central to the question. \$\endgroup\$ – Marcus Müller Nov 4 '17 at 11:52
  • 2
    \$\begingroup\$ You seem to be doing everything right. You can test the mA fuse as follows: Red lead into VΩ socket. Dial to 200 Ω range. Red probe into mA socket. You should read close to zero if the fuse and internal current shunt are OK. (This works because the other end of the shunt is connected to COM so it's the same as touching the red probe to black.) \$\endgroup\$ – Transistor Nov 4 '17 at 12:00
  • 3
    \$\begingroup\$ (and: have you verified the resistor is 1 kΩ?) (by the way, the "k" in kΩ / kOhm is small; capital K is Kelvin) \$\endgroup\$ – Marcus Müller Nov 4 '17 at 12:00
  • 1
    \$\begingroup\$ The lead is the flexible cable. The probe is the pointy bit at the end. \$\endgroup\$ – Transistor Nov 4 '17 at 12:19
  • 2
    \$\begingroup\$ Looks to me like your multimeter is broken. I'd guess that a connection to its internal current shunt is broken/open-circuit. \$\endgroup\$ – brhans Nov 4 '17 at 13:45
1
\$\begingroup\$

First of all, thanks for all your answers and proposals. As @brhans said, something could be broken, so I checked the internal connections from the mA input. Very soon I had to remove the dial to keep following the lines (broke that too, but managed to fix it) and I got in a place where something looked kinda strange.

A very small black thingy (could be a diode) was broken and one part was at a 90 degrees angle with the other while remaining soldered. It seemed like it was soldered that way to begin with (though I remember I used to be able to measure current before, but I'm not sure I even knew how when I bought it).

I shorted where it was supposed to be and tried to measure again and this time I got a value! I soldered to keep it shorted, screwed the multimeter and it seems to be working fine now. Though I still haven't ascertain the values I measure with the theory... I'll edit when I do.

Thanks again everyone!


Edit:

schematic

simulate this circuit – Schematic created using CircuitLab

With this schematic I took some measurements, changing the R1.

Resistance - Measured Current (Theoretical Current) Scale
47k - 0.129 (0.128) 2m
10k - 0.607 (0.6) 2m
1k - 5.49 (6.0) 20m
470 - 11.42 (12.77) 20m
330 - 16.14 (18.18) 20m
165 - 1.0 (36.36) 200m
110 - 1.4 (54.55) 200m

So I can see that the 2m scale is highly accurate, then the 20m is somewhere close and then there is the 200m...


Edit2:

I remember seeing some potentiometers inside the multimeter, so I opened it once again. I tested for DC current, voltage and resistance while toying with them.

The 2 potentiometers at the bottom seemed to change nothing, so I returned them to their starting value (I hope so anyway).

The 1 at the top though, had some effect to DC current and voltage measurements. Unfortunately the effect was across every range and in anyway was more of a finetune. So I returned that too to starting value and now I'm left with accurate measurements up to 2mA, close enough up to 20mA and then I have to go to the 20A input and see up to 2 decimals...

I'm not a professional, so I can deal with that, since it's fine to help me find the current requirements of different components and the rest I can find from Ohm's law.

Cheers!

\$\endgroup\$
  • \$\begingroup\$ Good work. Now you should perform a calibration check. Use Tony's schematic and measure the supply current in ammeter mode. Then measure the voltage across the resistor and see if the calculated current matches. There's a small chance that you could have a common V and A calibration error but it's unlikely as the V ranges worked but A didn't. You can mark your own answer as correct since it worked for you. +1 to give you some rep. for posting the answer. \$\endgroup\$ – Transistor Nov 4 '17 at 15:08
  • \$\begingroup\$ I just completed a test of my own, with 2 different resistors. I just connected the 6V battery with a 330Ω resistor and (in a different test) with a 1kΩ resistor. Through theory I found the 330Ω should result in 18mA and the 1kΩ should result in 6mA, but I ended up measuring 16mA and 5.5mA respectively. Should I change the simple soldered short with some... diode or something? Or should I just multiply everything by about 1.1? XD \$\endgroup\$ – Dimitris K Nov 4 '17 at 15:16
  • \$\begingroup\$ Without a schematic I couldn't hazard an answer. \$\endgroup\$ – Transistor Nov 4 '17 at 15:23
  • \$\begingroup\$ @DimitrisK It is possible that the battery voltage drooped a little with a resistor connected. You could measure the voltage across each resistor to check. The difference seems to be a bit too much to be accountable for by the burden voltage. \$\endgroup\$ – Andrew Morton Nov 4 '17 at 19:05
  • \$\begingroup\$ @AndrewMorton The voltage drop was insignificant, if any. From my understanding, shouldn't the resistance (in series) limit the current, while maintaining the voltage across the start and end of the circuit same? \$\endgroup\$ – Dimitris K Nov 5 '17 at 5:51
0
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

Be sure to use DC scale --__ not AC "~"

\$\endgroup\$
  • 1
    \$\begingroup\$ I don't understand the point of this schematic. Wouldn't AM1 and AM2 produce the same results? And what is the point of AM3? \$\endgroup\$ – Dimitris K Nov 4 '17 at 12:24
  • \$\begingroup\$ read again. VM1, VM3 can measure current just like AM1, or AM2 and AM3 says this will blow fuse so do not attempt this. (big X) get it? VM2=Vf @ If. You can insert R before or after LED but on GND side it is easy to use common Gnd to measure both Vbat and If(mA) across series R. If( 6-2v,red)/200 ohms=20mA. I think you must have used AC mA =0 \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Nov 4 '17 at 13:19
  • 1
    \$\begingroup\$ @DimitrisK: Tony's suggestion about measuring voltage across a resistor is a workaround to enable you to calculate current from the voltage drop across a constant resistance. (This is effectively what your multimeter does on current measurement but with a much lower value shunt.) Generally the "1999" (3+1/2 digit) meters read full scale at 199.9 mV so you can estimate the internal shunt resistance value from that. \$\endgroup\$ – Transistor Nov 4 '17 at 14:15
  • 1
    \$\begingroup\$ Oh, now I get it. And it would be what I would do if I was in a phase where I really knew what was going on. I'm still trying to establish my knowledge, so I really want to see everything measured and then do the calculations to see that I have the theory correct. \$\endgroup\$ – Dimitris K Nov 4 '17 at 14:49
  • 1
    \$\begingroup\$ This ignores the actual question though. \$\endgroup\$ – pipe Nov 4 '17 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.