1
\$\begingroup\$

PWM DC motor speed regulator

Hi, I just bought one of these PWM DC motor speed controllers, powered it using a 24(V) 10(A) power supply and attached a high rpm DC motor to it for a few seconds, increased and decreased the speed with the potentiometer and everything worked fine the first time. The second time I did the same setup, however, now it looks like the speed control module always outputs the same voltage available to it, regardless of the potentiometer's position.

Nothing smells or looks burnt or anything, and I also desoldered and tested the potentiometer, and it worked fine. I used a multimeter and found out that the DC motor actually draws much more than 10amps - which I thought it wouldn't since the PSU's highest current was advertised to be 10amps. I don't know how it's possible though - and possibly that high current draw damaged a component. I'm a neophyte here and I need help identifying the problem, just hoping to be able to change the faulty component.

Thank you very much.

UPDATE:
this is the best datasheet I could find for the DC motor (ERS-550SM 7520): http://www.evermotor.com/link/ERS-550SM.html
Although I wasn't lucky with the PWM module and didn't find anything whatsoever.

UPDATE 2:
As dear @Bruce Abbott suggested, I checked the resistance between the pins of all three FETs (those with heatsinks!), and the one with the larger heatsink has almost NO resistance between any two pins. So I guess that's the problem, isn't it?

\$\endgroup\$
  • 1
    \$\begingroup\$ Please add a link to the motor datasheet and a schematic (use the button on the editor toolbar) of how it's all wired up - otherwise we're all just guessing. \$\endgroup\$ – Transistor Nov 5 '17 at 23:33
  • 1
    \$\begingroup\$ Troubleshooting a circuit that you don't have a schematic for is going to be a bit iffy. The general approach for this sort of thing is "half splitting" where you look at a part of the circuit between the potentiometer and the output and see if it's working properly when you turn the pot. If it's not, the problem is before it. If it is working, the problem is after it. Ideas of places to check: output of the pot in the circuit, output of whatever creates the low voltage PWM, output of any transistor gate drivers that are receiving the low voltage PWM, and final output of the transistors. \$\endgroup\$ – Luke Nov 6 '17 at 1:01
  • 1
    \$\begingroup\$ Most likely the motor control FET (on the large heatsink) is shorted between Drain and Source. Using a digital multimeter, measure resistance between Motor - and Power -. If the reading is less than 10 Ohms the FET is probably shorted. \$\endgroup\$ – Bruce Abbott Nov 6 '17 at 2:53
  • 1
    \$\begingroup\$ A controller advertised as 10A may do one of several things if the load tries to draw more than that. (a) limit the current to 10A safely, (b) allow it to draw more for a while, then go bang. There are other behaviours, but these are the most common. The difference tends to be the cost of the circuit, an ultra-cheap part is more likely to b than a. \$\endgroup\$ – Neil_UK Nov 6 '17 at 6:17
  • \$\begingroup\$ Thank you all very much for helping me. I updated as much info as I could. Though I believe I found the faulty part, after performing a test @BruceAbbott suggested, but I'm totally open to your further suggestions. \$\endgroup\$ – Ali Nov 6 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.