0
\$\begingroup\$

I was reading part of the hspice tutorial, I found that, there is a multiprocessing option:

"hspice -mp [process_count] -mt [thread_count] -i input.sp -o output_file" "Note: Running both MP and MT simultaneously is limited only to LINUX."

Is there anyway to use those options on Ubuntu system? I tried it, I got "Syntax error: Bad fd number".

\$\endgroup\$
  • \$\begingroup\$ What was the exact command you have run? This is a generic linux error when tying redirect the IO stream in a shell ubuntuforums.org/showthread.php?t=1460684 \$\endgroup\$ – Eugene Sh. Nov 6 '17 at 18:51
  • \$\begingroup\$ @EugeneSh. Yes, when I was searching it, I noticed many people faced it when they were doing other simulations. I ran this option on linux and Ubunto system. The Ubuntu system gave me this error and linux was fine. Therefore, I thought maybe Ubuntu is the reason. I used: "hspice -mp -i xxx.sp" \$\endgroup\$ – Shabnam Nov 6 '17 at 20:04
0
\$\begingroup\$

I had the same issue. I had to change the /bin/sh link from dash to /bin/bash:

sudo rm /bin/sh
sudo ln -s /bin/bash /bin/sh

Thanks to this bug report for the idea

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.