2
\$\begingroup\$

I have tried to add a third party model to my LTspice program (2016 version) but when I run the simulation many errors show up. The model is made for PMOS and NMOS ( saved at the same link) Link of the models:(http://ptm.asu.edu/modelcard/180nm_bulk.txt). I have followed this tutorial (http://www.linear.com/solutions/1083) to add the models. Here is the circuit that is needed to be simulated to find the DC operating point and the AC gain.

1

Here is my schemetic: 2 I have used .inc order and I have used the SAME link for each of NMOS and PMOS. I In the model text file:

   .model NMOS NMOS
    +Level = 49
        bla  bla 

    .model PMOS PMOS 

the words NMOS and PMOS are repeated twice. I think one of them will be set as value for NMOS/PMOS in LTspice and the next word must be set as prefix in Ltspice as I understood. However, the program does not recognize the elements if I change the prefix part of NMOS/PMOS from "MN"/"PN" (original prefixes) to "NMOS"/"PMOS". And if I don't change the prefix a long list of errors shows up too. Here is my error for DC sweep for example:

(https://textuploader.com/dlynf)

Why are these errors happening? Are there built-in errors in the model file? How can I set W/L for the MOSFET? The errors occur also When I give DC voltage the source "V2". Should I use the models in separated files for each? In such a circuit to determine the input impedance I should apply Vin/Iin when Iout=0 and for output impudence I should apply Vout/Iout when Iin=0 and deactivate all the independent sources. Can I do this in LTsipce?

\$\endgroup\$
0
\$\begingroup\$

In the model card, the first "NMOS" is the name of this model. It could be "IRF544" or "MyMosModel" or anything else instead. The second "NMOS" says that this is a model for an N-channel MOSFET.

In LTSpice, the device itself will produce a line in the netlist file like

Mxxx Nd Ng Ns Nb <model> [m=<value>] [L=<len>]

Whatever you fill in for the <model> field is the model card the simulator will refer to to define this device.

Your error messages have a number of lines like

Ignoring BSIM parameter XL

This basically means that the model files you got from the third party are not compatible with LTSpice. They contain parameters that LTSpice does not understand. (I've confirmed that LTSpice does not have an XL parameter in its MOSFET model)

You will need to find out what SPICE the model files are meant to be used with.

Then either find and use that SPICE, or find its documentation and work out how to translate the parameters from that SPICE to parameters that LTSpice does understand.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.