I've always been a bit confused by altium designer. I am trying to create a small FET switch PCB for the following 3 speed DC fan system:

enter image description here

So for each output of the PWM ports used in this image I am producing 2 identical MOSFET switching circuits with off board connections to the UNO and one of 2 DC fans. Here is the schematic for the switch circuit:

enter image description here

And here is the PCB I have created by importing from the schematic:

enter image description here

So the problem I am having is that no ratnest appears between pin 1 of the FET and the other pin on R2. I have tried updating the changes from the schematic to the PCB already and I can't see why it wouldn't be there looking at the schematic. Any suggestions?

Thanks in advance,


  • 1
    \$\begingroup\$ Thoughts: 1. Is it possible the wires or the pins in the schematic are slightly off grid, so there's no actual connection to the pin? 2. Are the pins of the schematic symbol mapped 1-to-1 to pins on the physical device (in the lower right area of the properties dialog for the component in the schematic view)? \$\endgroup\$
    – The Photon
    Nov 15, 2017 at 5:58
  • \$\begingroup\$ Is it possible the pin on the schematic symbol (defined in the library file) is turned around so the wire is connected to the wrong end of it? \$\endgroup\$
    – The Photon
    Nov 15, 2017 at 6:01
  • \$\begingroup\$ Do you see any error messages when annotating from the schematic to the PCB file? \$\endgroup\$
    – The Photon
    Nov 15, 2017 at 6:02
  • \$\begingroup\$ Completely unrelated - your input multio-position switch assumes that your arduino has builtin pulldown resistors - depending on the chip it may only have pullups - you're better off tieing the common on the switch to ground \$\endgroup\$
    – Taniwha
    Aug 5, 2018 at 11:37

1 Answer 1


So let's get this out of the way first, I usually don't like routing a PCB while the rat's nest is enabled. I think it's more confusing than anything. However, if you want to display it you can go to the "view" tab and find "connections" at the very bottom of the drop down menu. You can then choose to display all, hide all, or hide certain nets. Of course, for the rat's nest to appear, the pins have to be connected in the schematic. In your PCB, you can double click on the two respective pins and check what net they are assigned to.

Finally, if none of this is helpful, maybe check the pin assignment in the schematic file? It has happened to me that I connected pins to the wrong nets, simply because I thought it was obvious where the connections had to be made, based on pin locations in the schematic.

  • \$\begingroup\$ Thanks but I solved this problem, the solution was in one of the comments. I marked it as helpful but this thread should really be marked as solved. \$\endgroup\$
    – burton01
    Nov 23, 2017 at 0:00
  • \$\begingroup\$ huh. I too find rat's nest visually confusing, but I'm so used to it I've never even considered turning it off. good tip about being able to hide certain nets for ratsnest, that could make for a nicer routing experience \$\endgroup\$
    – Ocanath
    May 22, 2020 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.