1
\$\begingroup\$

I have SIM800L module,

when I try AT+CSQ it returns 0,0

when I tried to remove the sim and try again it returns number, 0 (25,0)

and I cannot register to a network

so AT+CREG? returns 0,2

should I activate something or do another command before trying to do CSQ or either connect to a network..

when I try: AT+COPS=?

it lists all networks available, but cannot connect to any of them

thank you

\$\endgroup\$
  • \$\begingroup\$ Try upgrsding the sim's firmware \$\endgroup\$ – MaNyYaCk Nov 16 '17 at 4:57
  • \$\begingroup\$ I did, I got the same result :( no luck \$\endgroup\$ – Hassan Ali Salem Nov 17 '17 at 9:27
  • \$\begingroup\$ AT+CSMINS? To check whether it can find sim inserted \$\endgroup\$ – MaNyYaCk Nov 17 '17 at 10:01
  • \$\begingroup\$ I hope you are using a 2G ready sim. \$\endgroup\$ – MaNyYaCk Nov 17 '17 at 10:03
  • 3
    \$\begingroup\$ Your SIM800 modules is resetting. See the power supply section of datasheet \$\endgroup\$ – MaNyYaCk Nov 18 '17 at 7:36
2
\$\begingroup\$

I found the solution, it was from the power it takes. when the module is trying to connect to a network it consumes a lot of power, so I lower down the resistor.

now it is stable and connect smoothly.

try to check your module datasheet and check the power consumption

| improve this answer | |
\$\endgroup\$
  • 2
    \$\begingroup\$ Congratulation on realizing that power issues were to blame, as they often are for these. However a fixed "resistor" does not belong in the power supply circuitry of this module. If you are using one, you are taking a horribly mistaken approach. Even engineering a suitable voltage regulator is enough of a challenge that many projects just run these off the single cell they were designed to use in their original life as limited-feature mobile phones. \$\endgroup\$ – Chris Stratton Sep 29 '18 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.