1
\$\begingroup\$

Hi, in my circuit I made ground plane and inside of it I need clear area without copper for anthena. So I have created polygon in tRestrict layer and used Ratsnest for reconection. It worked, but not correctly. Copper was gone, but it took more copper than it should. It took 0.2mm more copper around each side of the polygone. I need ground plane align precisely around the polygon.

I think the isolation around polygon was created because ground plane polygon has column for isolation set to 0.2mm. How can I change isolation just for restrict polygon and keep it for other objects? If I think wrong and the problem is somewhere else, how can I fixe it?

enter image description here

\$\endgroup\$
  • \$\begingroup\$ My answer to that question shows how to use a cutout polygon to remove a section of a plane to the exact shape desired without the isolate setting causing an issue. \$\endgroup\$ – Tom Carpenter Nov 18 '17 at 11:57
0
\$\begingroup\$

First of all, my internet is off and I'm on my mobile, so I can't post screen shots. I'll do that later and go in in more detail.

You are right, it's due to the isolation, and net classes would be a solution. Typically, you would like to have more isolation for high voltage signals, or thicker tracks for high current signals, while all other signals can follow the standard design rules. And that's exactly what net classes are for.

In your case, create a new net class with isolation 0, and assign the signal GND to this class. Now, there will be no more space between your rectangle and the polygon, while the polygon respects the isolation of all other signals being in other net classes.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.