2
\$\begingroup\$

I often find myself clicking on a PCB component in Altium and accidentally dragging it ever so slightly. Altium then draws a bunch of green circles with X's in them, which I believe means there is an overlap problem (not enough room for the move). See image below:

enter image description here

My issue is that even after I press CTRL+Z (undo), the moved item is returned, but the green X's are not removed. This is a problem for reading text on nets and pins, and making screenshots.

The only solution I have found is to close the PcbDoc and re-open it, which is in no way convenient.

How can the error markers be removed without reopening the file?
Bonus question: Is there a way to disable the ability to move the component in the first place?

\$\endgroup\$
  • \$\begingroup\$ You'll probably need to run the design rule check again (T-D-Enter). Problem is this'll check the entire board for errors. You may have better luck going into the "Rules to Check" dialog in the design rule checker (T-D) and unchecking "online" for the rules causing this error. This would be a one-time change, but just remember during placement that your clearance rules may not show as being broken until the batch DRC is run \$\endgroup\$ – DerStrom8 Nov 21 '17 at 18:12
  • \$\begingroup\$ @DerStrom8 Yep, the rules check fixed the problem. \$\endgroup\$ – Bort Nov 21 '17 at 19:49
2
\$\begingroup\$

The direct solution is to go to the top menu: Tools > Reset Error Markers

...Or simply press T then M

Running a Design Rule Check will also remove the error markers, but seems to disable them completely until the file is re-opened.

\$\endgroup\$
1
\$\begingroup\$

It looks like there is a polygon pour in your picture. In this case, right-click on the pour and select "repour polygon" which will redraw it and should get rid of the violations.

You can also activate auto-repour, but it can slow things down if you have large polygons.

To disable moving the component, open its property page and click the "Locked" checkbox. This is quite useful, as you will now be able select stuff like tracks and vias under the components without Altium asking you every time exactly what you want to select...

\$\endgroup\$
  • \$\begingroup\$ That image is just a random example. When right clicking anywhere in that image, "repour polygon" is disabled. (The example image is from a large board that I did not originally design, thus I haven't inspected it in full detail yet.) \$\endgroup\$ – Bort Nov 21 '17 at 19:48
0
\$\begingroup\$

Bonus question: Yes. You can lock the component. For instance from PCB list, with the checkbox column "Locked"

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.