12
\$\begingroup\$

I bought a small 10 W solar panel which is rated to deliver 570 mA at its peak, according to the specifications:

  • Power: 10 Watt
  • Max. Voltage: 18 Volt
  • Max. Current (Imp) : 570 mA

So I bought a step-down converter that drops the voltage from 18V to 5V. Then I connected a USB port to it to charge the phone. Now, the problem is that it takes days to charge the phone battery, which is rated at 7.22 Wh.

So with a maximum power of 7 W from the panel (let's say that it will never reach 10 W), it should charge the phone in roughly one hour. Well, this is not happening and I would like to know why...

I initially thought it is the converter, so I have tried also with a 5V Voltage Regulator (the well known LM7805), and it has the same problem. Moreover, when I use an LM7805 and connect the phone, the voltage drops to 3V, so I suspect that there is not enough current from the panel.

The Step-down converter is this one, which has the specifications:

  • Rectification: non-synchronous rectification
  • Input voltage: 7V-35V
  • Output voltage: 1.25V-30V
  • Output current: adjustable maximum 3A
  • Conversion efficiency: 92% (the highest)

So I have these two voltage regulators, and it takes days to charge a phone. Now, the question is: am I doing/understanding something wrong or can the solar panel not handle this? Is there any way to check this out?

EDIT: After seeing the comments and the answer, I tried to measure the current in full sun. I get this:

Photo of digital ammeter reading 0.7mA

This mean that the current is 0.7 mA, right? It's the first time I'm doing this and I followed this sketch to measure the current with a multimeter:

hand drawing of circuit to measure current

In my case, the battery is the solar panel and the light bulb is the phone.

I hope the measurement is correct.

\$\endgroup\$
  • 3
    \$\begingroup\$ With the phone connected, and the sun at its brightest, measure the current and voltage coming from the solar panel. Multiply them, and that tells you how many watts your solar panel is supplying. Its probably a lot less than you think. \$\endgroup\$ – Steve G Nov 29 '17 at 11:47
  • 1
    \$\begingroup\$ google "maximum power point" \$\endgroup\$ – PlasmaHH Nov 29 '17 at 11:48
  • 1
    \$\begingroup\$ Note that the maximum current (short-circuit) and maximum voltage (open-circuit) doesn't occur at the same time for solar cells. So multiplying them does not give you the maximum attainable power output of the cell (10W in this case). It will be more something like 2W at full sunlight, so 1W in real life ;) //EDIT: Sorry I missed that the 18V/570mA is indeed at the max. power point (Imp, Vmp) and not open-/short-circuit (Isc, Vsc) values. \$\endgroup\$ – DerManu Nov 29 '17 at 11:51
  • 6
    \$\begingroup\$ You have the meter on the 200mA range but the red lead is in the 20A socket. Leave the lead where it is. On your meter it look like you should change the range to 20mA (20A in yellow). Try again. \$\endgroup\$ – Steve G Nov 29 '17 at 12:20
  • 3
    \$\begingroup\$ You're in the wrong socket. The meter's rotary switch has a legend around the outside indicating which range you are in. Near those markings is a "20A" icon only for those positions where you should be in the 20A socket. You are not in one of them. \$\endgroup\$ – Harper Nov 29 '17 at 15:29
25
\$\begingroup\$

First make sure everything is working as intended. Point the solar panel at full sun and see what kind of current you can get at 5 V. Try a 5 Ω power resistor. That should draw 1 A, which takes 5 W of power at 5 V. You should be able to get at least that according to your specs.

If that works, it may be that the phone is expecting a "smart" charger. It uses the USB charging protocol to communicate with the charger to find how much current it can draw. If it can't talk to the charger, the phone falls back to a rather low current.

Measure the current with the phone connected, first making sure the output really is at 5 V.

\$\endgroup\$
  • 1
    \$\begingroup\$ Thank you for the answer. I will try with a resistor. You might be right, because the phone says "Connect to an original Samsung charger", although it shows charging \$\endgroup\$ – Physther Nov 29 '17 at 12:09
  • 5
    \$\begingroup\$ @Physther The simplest standard for USB charging (Dedicated Charging Port) is to short the two data pins. Without this, many devices won't pull any more than 0.5A. (Technically, as a DCP, you're supposed to provide at least 0.5A at the rated voltage, but not being able to maintain that shouldn't be a problem...) \$\endgroup\$ – Bob Nov 29 '17 at 14:03
20
\$\begingroup\$

You're hooked up wrong.

The meter's big rotary switch has a legend around the outside indicating range. Obviously, there are as many range markings as there are switch positions. Only two of them have the "20A" icon, which indicates you should use the 20A socket instead of the V/ma/ohm socket.

You have not selected one of those positions, yet you are using the 20A socket, That's not going to work. You're sending the power through the ammeter shunt, but the meter doesn't know to rescale.

Try turning the meter knob one notch clockwise.

If that yields a measurement that is too small or out of range, then select an appropriate range and use the other socket.

\$\endgroup\$
  • \$\begingroup\$ The two "20A" Icons indicate the AC-Current and DC-Current Groups (max. 20A). It looks fine for me. \$\endgroup\$ – Robin Dec 6 '17 at 7:55
2
\$\begingroup\$

Please note that some USB connectors in cars show the same performance even though the battery of car rated 120AH. Phones require special charging circuits. You may need to solder a few resistors between power lines and D+/D- lines.

Please check: How do I design a 2A or more power supply for my consumer USB devices?

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.