3
\$\begingroup\$

I'm using a bluetooth keyboard which need four AAA batteries. After the cells are charged (at least according to the charger), the keyboard still doesn't work properly; there is a green LED that should stay lit for a few seconds, but it's red and blinking instead.

I'd like to know if the cells are actually charged. The battery specification is: AAA, 1.2V, 1000mAh. Once charged, my voltmeter reads 1.43V on each cell.

\$\endgroup\$
4
\$\begingroup\$

How can I measure the charge of a rechargeable cell?
I'd like to know if the cells are actually charged.
The battery specification is: AAA, 1.2V, 1000mAh.
Once charged, my voltmeter reads 1.43V on each cell.

You cells are fully charged.
I assume that they are NimH (Nickel metal Hydride) cells but that voltage would also indicate full charge for NiCd cells.
I use a nominal figure of 1.45 V / cell at 25 degrees C as end point when actually charging. If they measure 1.43V/cell when off charge that is even higher than I'd usually expect. If that is an on-charge figures at end of charge it indicates full charge.

A system intended to operate from NimH cells should work down to 1.1V/cell in all cases and ideally down to 1V cell. When lightly loaded (say C/10 load or less) NimH cells will operate at about 1.2 V across the major part of their discharge cycle. The keyboard should load them to far less than C/10.

Likely options in order of decreasing probability are

  • Your bluetooth keyboard is faulty

  • The red light indicates some other problem such as a lack of link connection from the "dongle" (aka receiver) that it connects via.

  • The keyboard needs Alkaline cells
    (but it should work on well below that voltage even with alkaline cells).

Thoughts:

I assume that the keyboard has a USB connected "dongle" which plugs into a USB port on your PC.

  • You do not say if this worked previously.
    If it was working and now isn't then a fault somewhere seems likely.

  • If you have not rebooted the system try doing so.

  • Try to minimise connection of other equipment which may cause interactions.

    • Sometimes other equipment plugged into the same USB hub causes problems.

    • Sometimes even equipment plugged into another USB port on the PC can cause problems .

  • On some occasions a device will "enumerate" on one USB port and then not operate on any other port.

  • Did the device came with drivers and did you load them?

  • Try it on another PC.

  • Is there a channel setting option which has been accidentally altered (most unlikely with Bluetooth).

  • Do you have other Bluetooth or wireless based equipment in use which may be interfering?

\$\endgroup\$
  • \$\begingroup\$ +1 for the mention of interfering wireless. This happened to me and took me quite some time until I noticed that my keyboard went rogue only when I wrote to my NAS... \$\endgroup\$ – 0x6d64 Jun 22 '12 at 11:21
  • \$\begingroup\$ Thanks for all your advices. I think that the problem what not related to the batteries, and I know now how to test them (see other answers). It was related to the USB hub which is currently under heavy load. I cannot unplug the drives which are connected to this hub right now, so I'm still not 100% sure. The red light seemed to indicate a lack of link connection from the dongle. Unfortunately the Macbook Pro I'm using has only 2 USB ports. \$\endgroup\$ – alecail Jun 22 '12 at 13:11
2
\$\begingroup\$

There is a possibility that the cells are damaged or just had to many charging cycles, so their internal resistance has become to large. This means that your multimeter still reads a voltage of 1.4XV after charging, but any significant load current leads to a breakdown of that voltage.

You could check that by measuring the cell voltage under load (say: about 100mA). The resulting voltage drop gives you an estimate of the internal resistance (this page talks about 0.17 ohms for a new, charged AA NiMH cell).

\$\endgroup\$
2
\$\begingroup\$

Sounds like the cells are probably okay. Measure the voltage with the batteries plugged and the keyboard switched on to make sure. Or just use a 10-50 ohm resistor across the battery and test the voltage. If it's still good then there's something else wrong.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.