1
\$\begingroup\$

I am trying to get -13.5V from mc34063.

On the first design, I used 8DIP package MDR34063AP and no problem getting -13.5V.

On the second design changed the package to 8-soic and used S1B-13F (100V 1A diode), which are replacements with same characteristics.

However, after 2 seconds IC starts to consume more and more current gets hot and burns.

When I increased the R22=1R resistor to 2.5R, it doesn't overheat but I can't get -13.5V anymore. It stays around -9V.

Any comment or help would be really useful,

Thank you for your time.

Design 1

Design 2 enter image description here

\$\endgroup\$
  • \$\begingroup\$ On second design, D7 is elsewhere. Not missing. \$\endgroup\$ – Alian4life Dec 21 '17 at 1:44
  • 2
    \$\begingroup\$ S1B-13F, 1N400x are inappropriate for SMPS designs- too long recovery time even for a pig of a chip like 34063- and not even specified. Use a Schottky diode like the datasheet shows. Is the inductor the same in both cases? \$\endgroup\$ – Spehro Pefhany Dec 21 '17 at 3:42
  • \$\begingroup\$ have a close look at the chip. there may have been a mixup with part numbers \$\endgroup\$ – jsotola Dec 21 '17 at 3:43
  • 1
    \$\begingroup\$ @SpehroPefhany Thank you so much Spehro, switching to Schottky solved the issue! Thank you for your help, sending you all the good karma! \$\endgroup\$ – Alian4life Dec 21 '17 at 4:43
4
\$\begingroup\$

1B-13F, 1N400x are inappropriate for SMPS designs- too long recovery time even for a pig of a chip like 34063- and not even specified so the specs can be met yet the diodes can be very different.

Use a Schottky diode like the datasheet shows. An ultra fast diode such as UF4004 can also be used.

Inductor saturation is another thing to look for if that part changed.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.