1
\$\begingroup\$

I'm trying to use the Deep Sleep feature of the ESP8266 with an inexpensive ESP-01 module. These need to be modified to bridge GPIO16 to RST, in order to wake up from deep sleep. Also, I have removed the power LED.

I'm using the Arduino implementation. The device enters deep sleep for the specified amount, and wakes up. The problem is: most specs state in this mode, current draw should be in the "sub-100uA" range. I'm seeing about 3mA.

I have lifted all pins, even the FLASH chip VDD, but I simply can't seem to reduce the current draw. I have measured with two different instruments and the current reads the same, about 3mA.

There is no regulator in the circuit as it's all running from a lab supply for now.

\$\endgroup\$
  • 1
    \$\begingroup\$ First things first, is your measurement solution (handheld multimeter? bench multimeter?) capable of reading in that range? A cheap handheld may have problems with burden voltage. \$\endgroup\$ – replete Dec 27 '17 at 3:42
  • 1
    \$\begingroup\$ It's a Fluke 107. It's an "electrician's multimeter". But the result is the same I'm getting with my DIY lab supply which has a MAX4080-based current meter. Both measure around 3mA \$\endgroup\$ – hjf Dec 27 '17 at 3:54
  • \$\begingroup\$ Is /CS being held high on the QSPI flash chip? \$\endgroup\$ – Spehro Pefhany Dec 27 '17 at 4:14
  • \$\begingroup\$ @SpehroPefhany interesting question and I did try that too. It's around 3V while Vdd is around 3.2V. I tried a 4.7K pullup between Vdd and /CS in the flash IC but nothing changed. \$\endgroup\$ – hjf Dec 27 '17 at 4:18
  • 2
    \$\begingroup\$ Any floating inputs? Also, have you tried another module? \$\endgroup\$ – Spehro Pefhany Dec 27 '17 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.