0
\$\begingroup\$

I have a transimpedance amplifier circuit with a Silicon Photomultiplier as shown below:

schematic

simulate this circuit – Schematic created using CircuitLab

We're using the SensL MicroFJ-60035 Silicon Photomultiplier and the AD8014 amplifier. My team shines a light pulse on the SiPM, and the transimpedance amplifier converts the current signal into a voltage signal which we read through the coaxial connector. The rise time of the current signal is approximately 20 ns.

However, we are experiencing clipping at 1.5 V at the output. Sorry, I don't have an image to show here right now. This type of behavior seems strange, and I was wondering what could be the issue that's causing it? I'm not an expert on amplifier behavior, but could something at the input or the op-amp parameters be causing the clipping?

Based on my knowledge, clipping only occurs when you try to drive a signal above the power supply limits, so I don't really know what to look for in terms of the cause. I'm don't know if the rise time directly corresponds to the input signal frequency, but we are achieving around 6-10 ns rise time of our signal, so assuming that we're working with a frequency range of 100 to 200 MHz, looking at the graphs in the AD8014 datasheet, could we be operating a non-linear region which could clip the output signal? The AD8014 has a large bandwidth of 400 MHz, so I would think that it's large enough for our needs.

EDIT: Based on the comments, there's something I wanted to note here that may help. Previously, my team used the OPA656 from Texas Instruments for our op-amp. Once we found that it was too slow for our needs, I looked at other op-amps with a faster slew rate. Thus, I went with the AD8014. It has a faster slew rate, and it has the same power source requirements as the OPA656, so I thought that it would be a viable substitute. We never had issues with the OPA656, but with all these comments, I'm trying to look and see how else they are different so that I may understand why we're having problems with the AD8014.

EDIT: This is a revised edit of a previous edit that I made regarding a simulation. Some tests that I ran show some things more clearly, so I wanted to note it here. First off, below is my simulation schematic that I'm using:

Sim Schematic

In this schematic, I'm using SPICE models provided by the appropriate manufacturers for the SiPM and the op-amp. In this case, the OPA656 is shown here. This is important for the next part, but please keep in mind that I'm comparing the behavior of the OPA656 and the AD8014 in the same circuit. I also have a model for that as well. V4 is the voltage source that 'triggers' the SiPM. It pulses once after a 10 ns delay, and it stays on for 200 ps. The SiPM turns on, and the current signal gets turned into a voltage signal, and it goes into a 0.6 meter transmission line model. I used stats for the RG-58 coaxial cable going to a 50-ohm load.

Below is the simulation results showcasing the voltage at the op-amp output, the start of the transmission line, and the middle and end of the transmission line as well as the current through the end load.

OPA656 results

It's a little hard to see, but I hope that the voltages are easy to understand. The current through the load resistor is at the top, and it goes up to a max current of around 17 mA. The voltage at the op-amp output reaches a peak of 1.7 V while the voltages at the line and load reach around 0.85 mV.

Below is the simulation result when using the AD8014 amplifier in the exact same circuit:

AD8014 result 1

Right now, the team isn't so much concerned about the amplitude of the voltage but more of its shaping. With a feedback resistor of 50 ohms, you can see a sort of 'double-peak' here with the AD8014 that isn't present in the OPA656. The OPA656 goes into a small peak only once where with the AD8014, you see it rises to a peak, and it doesn't fall immediately but rather levels off kind of like there's a second peak.

I not only see this type of behavior at 50 ohms, but I also see some similar behavior at larger resistances as well. Below are images of the OPA656 and the AD8014 when the feedback resistor is 470 ohms, respectively:

OPA656 results 2

AD8014 results 2

Again, you can see here how at the load, the AD8014 reaches a peak, goes down, and levels off in a sense. You don't see it here with the OPA656. I'm not familiar with behavior like this, but what would cause this kind of pulse shaping to occur among op-amp circuits?

\$\endgroup\$
  • \$\begingroup\$ For me, clipping only occurs when you try to drive a signal above the power supply limits You should also consider the case where for example a current of 100 mA is needed (to drive the load at the output of an opamp) but the output of the opamp can deliver only 70 mA (the AD8014's short circuit current). That will also result in clipping. \$\endgroup\$ – Bimpelrekkie Jan 8 '18 at 17:30
  • \$\begingroup\$ @Bimpelrekkie Thanks for your reply. Right now, we're just hooking it up to a 50 ohm oscilloscope, so I wouldn't think we need to drive a lot of current. We're also considering the case that it could be due to the feedback resistor, so we're playing around with the values of it to see if it makes any difference. \$\endgroup\$ – user101402 Jan 8 '18 at 17:50
  • \$\begingroup\$ up to a 50 ohm oscilloscope, so I wouldn't think we need to drive a lot of current. Why not? I think the current is to high. I challenge you to prove me wrong by actually calculating that current that is needed (I'm too lazy to do it for you). \$\endgroup\$ – Bimpelrekkie Jan 8 '18 at 18:21
  • 1
    \$\begingroup\$ From spec sheet: Output Voltage Swing with RL = 150Ω ±3.4V (min)......you're loading output with about 70 ohms instead of 150. \$\endgroup\$ – glen_geek Jan 8 '18 at 18:40
  • 1
    \$\begingroup\$ When you say " we're experiencing clipping at 1.5v @ output", are you seeing a 1.5V pulse amplitude when oscilloscope is connected to R4 through a 50 ohm cable (to a 50-ohm input Z 'scope)? ie: R4>cable>50ohm'scope. That would put op-amp output pulse amplitude at 3.0v, which is close to its voltage limit. \$\endgroup\$ – glen_geek Jan 8 '18 at 19:42
2
\$\begingroup\$

Regarding AD8014 output characteristics, from the data sheet. This with +/-5V power supply:
AD8014 output drive
In your transimpedance circuit R3, a 235 ohm resistor appears to the output as a load resistor to ground. Its parallel 3pF capacitor also loads the output, but is nearly insignificant compared to the resistive loading.
R4, a 50 ohm series resistor is assumed to be closely associated with the output pin of AD8014. It would drive a 50 ohm coaxial cable to provide an output signal. That coaxial cable should see a 50 ohm load resistance at its far end, to prevent pulse reflections. R4 in series with this 50 ohm load would be seen as 100 ohms to the AD8014 output.
Total load at the AD8014 output would be 235 ohms in parallel with 100 ohms: about 70 ohms. Since data sheet (above) stops at 150 ohm load, it is somewhat dangerous to extrapolate down to 70 ohms. It appears that at 150 ohms, output stage requires a voltage overhead of 1.6 volts...(5V - 3.4V)....certainly when loaded with 70 ohms, overhead will be higher. It would seem reasonable that the output stage enters voltage limiting somewhere above +3V. Since R4 forms a voltage divider with the far-end 50 ohm load, half of this 3V limit would be all you could expect with a Vcc=+5V.

Output swing also has a current limit of 40 mA. This means that a total load resistance any lower than 75 ohms would limit output to +3V.

Your design is very close to voltage limiting, and to current limiting. If you want to increase these limits, you must raise Vcc and you must find a way to raise the total load resistance.


Edit Every op-amp's output has voltage overhead (even rail-to-rail has a little). Voltage swing is limited by this overhead, which subtracts from the DC supply voltage. Overhead voltage is weakly dependent on current, just as transistor saturation voltage is dependent on current flowing through the transistor.
Lightly loaded with 1k ohm, overhead is 1.4V. With a +5V supply, output voltage cannot reliably rise above 3.6V.
Loaded more heavily (150 ohm) overhead increases to 1.6V...output voltage cannot reliably rise above 3.4V. This is with a supply of +/-5V. Since this overhead subtracts from supply voltage, output swing can be increased by increasing supply voltage. Since your photodiode circuit swings only positive, it should be possible to improve voltage limiting by increasing +ve supply voltage (and perhaps decrease -ve supply voltage: you have an absolute maximum supply limit of 12V).

It appears that Analog Devices designs this device for a 50 ohm load, and specifies that output will reach +2V with such a load, drawing 40 mA. The spec suggests that output current above 50 mA should not be expected. Hard current limiting occurs at 70 mA.
Combining voltage swing limit with current limit sets the minimum resistance seen by the output pin: \$ \frac {3.4}{0.05} \$ = 68 ohms. This is very close to your current design. If you raise supply voltage to increase voltage swing, current limiting still applies....raising load resistance will be required to reduce current.
R4 need not be 50 ohms. It is most important to match cable impedance with an equal load resistance at its far (oscilloscope) end. However, lowering R4 will load the op-amp more heavily, and you run afoul of current limiting. Raising R4 to 470 ohm would result in far less voltage at the oscilloscope end, which must terminate with 50 ohms.
If you must connect a load via coax cable, a choice of RG-59 (75 ohm) or RG-62 (93 ohm) would be better, naturally with an appropriate termination resistor value. OPA656 has slightly stronger output stage - if this gave acceptable output, then raising output resistance this way should be good. With 75 ohm coax, you can reduce R4 to 25 ohms. If this is not an option, then this device is too feeble to supply more output signal.

\$\endgroup\$
  • \$\begingroup\$ Thanks for your reply. If you don't mind, I'd like to ask some questions to confirm some stuff. In reality, you can't go rail to rail, so the output voltage swing is essentially the limits of how high/low the output voltage can go given the load resistance correct? Also what exactly is the voltage overhead, and how is it important? If it's how you said, is it dangerous to assume the oscilloscope as just a 50 ohm resistive load? That seems to cause a lot of problems in design. If we increase R4 say 470 ohms, that's closer to 150 ohms for the output but wouldn't that cause impedance mismatch? \$\endgroup\$ – user101402 Jan 9 '18 at 14:14
  • \$\begingroup\$ Apologies, but I'd like to add that previously, we used the TI OPA656 op amp, and we never had any problems with it, no saturation or the like. I tried switching over to the AD8014 due to its faster slew rate, so based on your answer, I'm also looking back at the datasheet of the OPA656 to see the differences in the output parameters between the two to understand the problem further. \$\endgroup\$ – user101402 Jan 9 '18 at 14:49
  • \$\begingroup\$ @user101402 have edited answer with updates, suggestions. \$\endgroup\$ – glen_geek Jan 10 '18 at 14:08
  • \$\begingroup\$ Thanks for your reply. I've been running some simulations using a model provided by the manufacturers for the op-amp and SiPM, respectively. As you said, the limiting factor here seems to be the output resistor and the power supply, but right now, team wants to keep it at 5 volts for now. I added an image of my simulation, and if transmission line effects are negligible, the output and load resistor act as a voltage divider, so load voltage is half of output voltage. In sim, if R2=0, load voltage goes up to 2.04 V with 41 mA, if we keep power at 5V. Wouldn't it be fine to operate like this? \$\endgroup\$ – user101402 Jan 17 '18 at 15:49
  • \$\begingroup\$ @user101402 the opamp is likely to be unstable directly driving any significant length of coaxial cable (=capacitance). You may want to use a separate buffer/power amplifier. \$\endgroup\$ – τεκ Jan 17 '18 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.