I am almost done routing a board. However, Eagle is telling me that there is still one more wire. I have looked but I just can't seem to find it. Is there a way to make Eagle tell me where it is?

  • \$\begingroup\$ There are other alternatives too. \$\endgroup\$ Commented Jul 2, 2012 at 23:10
  • \$\begingroup\$ I don't use Eagle, but can't you just run a DRC and it will tell you which nets are not connected? \$\endgroup\$
    – Oli Glaser
    Commented Jul 3, 2012 at 1:28
  • \$\begingroup\$ @OlinLathrop what are the other options? \$\endgroup\$
    – Alexis K
    Commented Jul 3, 2012 at 2:22
  • \$\begingroup\$ @AlexisK Check the updated answer fore more options. \$\endgroup\$ Commented Jul 3, 2012 at 9:40

7 Answers 7


I can think of three options:

  • Zoom out as much as you can then use the route tool on the tiny board, this catches the air wire, then zoom in again and route it.

  • You can also disable the top and bottom layers so the air wire becomes more visible.

  • Yet another option is to run the provided "length.ulp" script (File->Run... or ULP button). This script shows a list of all the nets, on that list there is a column "Unrouted", some net is not completely routed a value should appear here instead of "--". You can then type on the command line "show net_name" to highlight it.

  • 1
    \$\begingroup\$ nice. I found it using the first method. \$\endgroup\$
    – Alexis K
    Commented Jul 3, 2012 at 16:27
  • \$\begingroup\$ On Eagle 5, I have a saved layer configuration called ‘airwires’ (it only shows the airwire layer). If I find I have a very short airwire somewhere, I zoom to view the entire board, then look for the wire. It's usually very obvious even on 6U Eurocard-sides PCBs. \$\endgroup\$
    – Alexios
    Commented Sep 24, 2012 at 13:55
  • \$\begingroup\$ The zoom out method is also illustrated in this blog entry. \$\endgroup\$ Commented Mar 31, 2015 at 1:17

There is an ULP called zoom-unrouted. When you run it, it will automatically zoom your view to the first airwire it finds. Very useful. Here is the link:


  • \$\begingroup\$ Yes, this is what I use mostly. Or else, hide all other layers besides "Unrouted" Layer. \$\endgroup\$
    – OrCa
    Commented Apr 12, 2013 at 12:42
  • \$\begingroup\$ This ULP is marvelous - I find hiding the other layers isn't much use when your airwires are miniscule little hops between not-perfectly-aligned pads and traces - shame you can't change the airwire display thickness (just color) \$\endgroup\$ Commented Apr 7, 2016 at 23:01
  • 2
    \$\begingroup\$ URL changed to cadsoft.io/resources/ulps/349 \$\endgroup\$
    – mash
    Commented Aug 12, 2016 at 7:40

Air wires are located on layer #19: "Unrouted". By disabling most/all of the other layers, they can easily be spotted.


Type in the following command: ratsnest *

This will list all the airwires in the status bar at the bottom with their name/net designation. It's a good start, and then at that point if you don't know where they are, use one of the above mentioned methods.

  • \$\begingroup\$ By far the easiest way I found to see if everything is routed. If it says "Ratsnest: 0 airwaves" in the statusbar then all is routed. \$\endgroup\$
    – HixField
    Commented Feb 6, 2017 at 21:06

I'm not an Eagle user, but you surely can selectively disable layers. Disable the most distracting layers, that will probably be your signal layers, so that only components remain visible. You'll probably see the line then.


I think that the fastest option is to select the Edit->Route and click with the left button of the mouse on the board. Automatically eagle will draw a track to the nearest untracked wire of the board (or to the latest unrouted wire, do not worry).

Some time ago I disabled all the layers except the "Unrouted" to look for the unrouted tracks, since I discover this simple and faster method.


Sorry to revive this ancient topic, but, I found a way optimal solution, available on eagle 7.6 at least.

Go to Options -> Assign... and create two shortcuts for the enabling the default view and another to enable the airwire view, as follows: Airwires' Assigned command: DISPLAY NONE; DISPLAY 19; Default view's Assigned command: DISPLAY NONE; DISPLAY 1 16 17 18 19 20 21 22 23 24 25 45 51;

Mileage may vary, as layer may (do they?) change through versions, so, it is always a good option to go to Layer settings and double check layer numbering.

Here, I have assigned on F11 to airwires and F12 to default. But these are just suggestions :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.