1
\$\begingroup\$

I want to build a robotic arm for a project, but I got stuck while testing the motor driver on the breadboard.

I have followed the instructions from this instructable: https://www.instructables.com/id/Easy-DC-Motor-Controller/ and I connected the pnp transistors the right way (the author confirmed in the commentaries a long time ago) and also like in the diagram.

The problem is that when I turn the power on, the motor starts to spin (slowly but it has a snail gearing reducer) and the first mosfet is getting very hot very quickly, and if I try to control the circuit by touching the first contact with a positive voltage it doesn't do a thing. I even tried doing only half of it.

I tried to reassemble it again many times, changed the transistors with other new ones, checked the connections and after numerous voltage measurements I concluded that the problem is that, when I am powering up the circuit, for some reason, there is a 12v voltage between the pnp collector and ground and the voltage continues all the way to the resistor to the far left, although at the resistor the voltage is dropped to about 7v. enter image description here

enter image description here I also simulated the circuit in proteus before i bought the parts (I need 6 good working drivers) and it worked fine.

enter image description here It may be a stupid mistake, but please help me if you have any idea what the problem might be!

\$\endgroup\$
  • 1
    \$\begingroup\$ "between the pnp collector and ground there is a 12v voltage and the voltage continues all the way to the resistor to the far left,although at the resistor the voltage is dropped to about 7v." - what are the part numbers of these components on the schematic? Have you checked that the transistors are connected the correct way around? \$\endgroup\$ – Bruce Abbott Jan 12 '18 at 6:40
  • \$\begingroup\$ For the purpose of troubleshooting I've made one half of it so let's say that at the 2n2907 Q3 transistor in the proteus schematic I always have 12v when I power on the circuit.In proteus on the other hand I have 12v at the colector only when the switches are properly actuated,in the mean time there is no voltage to open up the fets. \$\endgroup\$ – Vlad Jan 12 '18 at 10:53
  • \$\begingroup\$ This is a simple circuit so a few voltage measurements should be sufficient to find the fault location. However your vague descriptions are making it much harder. Which part is "the resistor to the far left", and where exactly is the voltage "dropped to 7V"? What are the voltages on each terminal of Q2 and Q3? Are the actual transistors the same as in the schematic, or did you substitute different parts? \$\endgroup\$ – Bruce Abbott Jan 12 '18 at 16:57
  • \$\begingroup\$ Thank you very much for your help! I made a simulation in proteus with the circuit I tried to do on the breadboard to make the circuit more comprehensible and it also worked. It looks like this: !Simulation I also did new measurements and checked twice. On the first column are the on the first column I wrote down the voltages with the motor disconnected from the circuit,on the second column are the values with the motor connected to it. !Picture \$\endgroup\$ – Vlad Jan 12 '18 at 22:28
  • \$\begingroup\$ EDIT:Sorry!I forgot to tell you that all the measurements are done without connecting the PIN1 to 12v. I took a picture of it to save some time,I hope you can understand my writing. Whenever I connect the motor to the circuit,it slowly spins and is heating up the fets. Connecting 12v to the PIN1 doesn't influence the motor,but if you think it helps I can make new measurements where you tell me. \$\endgroup\$ – Vlad Jan 12 '18 at 22:36
0
\$\begingroup\$

In the comments you link to a picture with these voltage measurements:-

Motor off:

Q3 Vbe = -0.656V

Q2 Vbe = 9.12V, Vce = 9.10V, Vbc = -0.0612V

Pin1 GND = 0.62V

Q3 is turned on because Q2 is pulling current through R4 and R6 to ground. But Q2 should be off, and even if turned on its Vbe should only be ~0.7V. The high Vbe suggests that Q2's Base-Emitter junction is either open-circuit or incorrectly wired, and the low Vcb suggests either a short circuit (leads touching?) or saturated Collector-Emitter junction (wrong transistor?).

Here are the pinouts for a 2N2222A:-

enter image description here

Your breadboard photos are not clear enough see where exactly where the leads are going, but it looks like Q2's Base and Collector are swapped around. Also I cannot see the part number. Are you sure it is a 2N2222A? If all this is correct then the transistor must be faulty.

\$\endgroup\$
1
\$\begingroup\$

I see NO reason this circuit will work. There is no boost gate supply for the high side and no dead time control.

Q5,8 needs 24V on gate Vgs when Vs is 12V and shoot thru must be avoided.

Far better designs exist. Dump this one... fast

\$\endgroup\$
  • \$\begingroup\$ Of course it will work, after a fashion. It simply won't provide 12 V across the motor since the upper FETs have a 2-4 V VGS(th). Depending on the current required by the motor, they circuit may work, or the two upper devices will tend to run hor. \$\endgroup\$ – Jack Creasey Jan 12 '18 at 6:28
  • \$\begingroup\$ But then why did it work on proteus and at other people that tried an thanked the autor which even posted a video of it working? \$\endgroup\$ – Vlad Jan 12 '18 at 10:58
  • 1
    \$\begingroup\$ For Nch the gate voltage must be much higher than drain. Quad Nch bridges always use PWM on low side to create a boost diode cap voltage for high side gate drive.& when Vgs(th) is 2~4V Drive must be 9~12V above Vd. \$\endgroup\$ – Sunnyskyguy EE75 Jan 12 '18 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.