5
\$\begingroup\$

I made a remote (GSM) controlled module for a 3 phase pump close to my friends house. The pump should run at night, and walking the 1km to the switch while they are sleeping is the problem.

The manual switch, switches 3 phases which is put through a 4 wire cable (no ground) to the pump 50 meters away and 20 meters down from the manual switch. At the pump there is a fusebox and a small box which switches off the pump in case there is no water output detected (the water pressure box). The pump pulls a max of 16Amp, the actual amount I don't know (the fuse is 16amp)

My module switches the 3 phase power using a solid state relay ( Eurotherm RS3DA 30A ). I see that the GSM part works and switches the Solid State Relay on, but the pump does not start.

I am not sure what this causes, I had no way to measure the output, just having a voltage screwdriver to test there is voltage on the output of the relay. At some point the pump after some resetting of the water pressure box) did work but it would never by just powering the whole thing via the relay. Pulling out the 3phase connectors out of my module and connecting them directly will start the pump without a problem.

(there is some waiting involved after running the pump, you cannot just switch it on and off).

At home I could not realy test the relay except for the GSM module (based on Arduino)

I am not sure why this does not work. Could the solid state relay change the 3 phase in such a way that this happens because of power loss (less Voltage?) Next time I am there (it is a 12 hr drive) I can bring my voltage meter, but it does only do one phase. Any other things I should buy and take along to test en compare the module in the real world? Would it help to put the relay after the fusebox? Should I look for a mechanical relay for switching the 3 phases? Will that solve my problems, or is it just neater (there is a fuse at the switch uphill as well).

If necessary I could hook into the water pressure module but that costs something in the order of 800 USD (my module was about 120 all in) so if I break that I might loose a friend (and my right to visit their remote place).

\$\endgroup\$
  • 1
    \$\begingroup\$ Some additional questions: What is the current rating of the output pins on the GSM module? What is the voltage of the 3-phase system? When you say a 4-wire cable, are you only using 3 conductors? How confident are you that you connected the relay and motor correctly? \$\endgroup\$ – W5VO Jul 3 '12 at 16:06
  • 1
    \$\begingroup\$ Have you connected a Wye motor as Delta? (4 wires vs 3?) Does the manual switch switch only the same 3 wires? Does the water pressure switch have an upper and lower limit, and have you confirmed that the pressure is below the lower limit when you trigger your solid state contactor? Does your circuit supply current to the contractor for a guaranteed minimum amount of time? \$\endgroup\$ – UnconditionallyReinstateMonica Jul 4 '12 at 0:58
  • \$\begingroup\$ @WSVO The relay control is directly connected to an Arduino pin. That should be enough according to the spec, but I have not checked that for lack of a Voltmeter out in the field ( will take one next time I drive there). The voltage is 3x230V (European style). As the motor has run via the relais I am pretty sure it is all connected correctly. It just does not want to start every time. \$\endgroup\$ – Anthon Jul 5 '12 at 8:58
  • \$\begingroup\$ @mickeyf: I have not connected anything else apart from a lightbulb, as I have no 3 phase devices at home. I made sure to wait a few minutes after the pump was run as I am aware of why the problems with restarting to soon. The manual switch migth switch the nul line as well, I wam not sure how to check that. I thought about controlling the relay with somethng else than the pin next time I am out there. \$\endgroup\$ – Anthon Jul 5 '12 at 9:03
3
\$\begingroup\$

You should be able to test this yourself at home using household AC mains live as one of the phases L1, and something like a lamp as the load on T1. Keep the lamp neutral going to the wall. Leave L2, L3, T2 and T3 disconnected. This should be easier to troubleshoot.

Crucially check the Arduino control output is holding a voltage over 4V when you are sinking the 50mA 'holding current' in the contractor. You can measure this by turning on the output and checking the voltage at +terminal of the contractor control pins. The device has the 'indicator LED', zero-crossing logic and three opto-isolators sat on your supply. You may find a small logic level MOSFET is needed to drive it, rather than an Arduino pin.

If your drive is inadequate you may be in the position where some, but not all phases fire, (given the zero crossing detect will stagger the start-up) which is not great for the pump as it will stall but still be dissipating power. So until you fix this, don't leave it running for long periods.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ After posting the OP, I realised the power might not be enough resulting (maybe this is nonsense) in quick switching on-off of the relay. Of course the lightbulb with which I tested this would not work. I tried driving the relay with just one phase at home, but that would not work. I did the checking with the bulb at the house of my girlfriends parents; they have 3-phase in their garage (just in case a contractor needs it, they have no devices). I will test switching the relay with an alternative to the arduino pin next time I am over there. Thanks \$\endgroup\$ – Anthon Jul 5 '12 at 9:07
  • \$\begingroup\$ @Anthon how did you get on? \$\endgroup\$ – shuckc Jul 10 '12 at 9:27
  • \$\begingroup\$ I have not been able to try this yet. The 'controller' module and the pump are in the south of France and I live in the north of Germany (a 12h drive). The module is not hooked up now, but thanks for the warning. I have ordered some parts and an extra Arduino ( I have a 2nd relay) to test things before I go. I will keep you posted as I get along. BTW the relay switches on 4-28VDC (>4 is on, <1 off) and is supposed to take 10 to 18mA, which I thought the Arduino could provide. Of course I should just have connected the +terminal to the 9V powersupply for testing when I was there %-) \$\endgroup\$ – Anthon Jul 12 '12 at 5:18
  • \$\begingroup\$ Intermediate update: I tried to prepare for this with a IRL7833 Mosfet, but I might have blown the two devices I had before I realised the pin layout (my voltmeter now shows no resistance between either combination of pins). I have made a small board with a transistor following the Arduino Cookbook (2nd ed. p 305) and that seems to drive the relais ( I have another one at home) more powerful. Could not test this with an Arduino, as the Arduino ADK that I bought seems to be broken. \$\endgroup\$ – Anthon Jul 20 '12 at 6:03
  • \$\begingroup\$ The relay is now for sure switching correctly, it might have done so before, I don't want to resolder everything now that the relay control gets 12V. The output is ok (230V) as well but when I hook up the pump control hardware, one of phases goes up to 400V and the pump does not work. When I hook up that single phase to the input of the relay the pump starts and runs, but it will not start normally. The pump control seems to have a mechanical relay (from the sound of it) which is depending on the waterflow (so it will not run dry). \$\endgroup\$ – Anthon Jul 31 '12 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.