0
\$\begingroup\$

I am trying to hook up an NPN transistor to emulate the circuit design here enter image description here

The poster calls for an SS8050 NPN transistor (datasheet is here) but all I have on hand is a BC547B (datasheet is here).

My circuit doesn't work so I removed the controller and wrote a simple program that just "turns on" the transistor for 5 seconds, then off for 2 so I could see what is going on with this thing. One thing I found is if I take the voltage between the collector and emitter when the base is on I get 0.275VAC which doesn't make any sense to me. Why is it outputting AC voltage when I'm not changing the gate at all? I assume this is the reason why my circuit doesn't work but the datasheet for this transistor doesn't mention AC voltage at all.

Can anyone shed some light on this? I'll buy some of the SS8050's that the poster recommends but I just want to know what is so different about my transistor that it refuses to act as a switch.

For people asking about the schematic. In order to reduce error on my part I duplicated the schematic provided by the poster here. The only difference between mine and his is my transistor is different and I unplugged the controller because it wasn't working as intended.

\$\endgroup\$
  • 6
    \$\begingroup\$ Please add a schematic of what you have done, it is difficult to determine what you did from the wall of text in a Reddit post. \$\endgroup\$ – Ron Beyer Jan 18 '18 at 5:37
  • 1
    \$\begingroup\$ You should also measure the voltage in DC mode, not AC mode. \$\endgroup\$ – mkeith Jan 18 '18 at 5:38
  • \$\begingroup\$ the schematic can be seen here. Mine is literally the same exact thing except I removed the controller and I have the different transistor \$\endgroup\$ – joshua0823 Jan 18 '18 at 5:47
  • 1
    \$\begingroup\$ Edit your question and include that picture. We're not going to follow a link from your comment. \$\endgroup\$ – Bimpelrekkie Jan 18 '18 at 6:32
  • 2
    \$\begingroup\$ @bimp don't be rude. New users cannot add images themselves. It's imgur and you could not be lazy and edit it in yourself. \$\endgroup\$ – Passerby Jan 18 '18 at 6:58
1
\$\begingroup\$

BC547B:

BC547B

SS8050:

SS8050

The transistors are interchangeable in this application, but their pinouts are opposite. Rotate your transistor 180 degrees and try again.

The AC you're measuring is probably just interference from mains AC wiring.


Beyond the simple transistor pinout issue, there is a problem with the circuit design.

Your Arduino is running from a USB power supply. The controller has a battery in it. To switch the transistor on, you apply positive \$V_{BE}\$. The Arduino applies a voltage relative to ground A. However, the emitter is connected to ground B. You need to connect the two grounds together so the Arduino-controller system has a common reference point.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • 1
    \$\begingroup\$ To the OP: This seems likely to be the answer. However, if it is not, please post your schematic by editing your original question and adding the schematic using the built-in schematic editing tool. \$\endgroup\$ – mkeith Jan 18 '18 at 5:39
  • 1
    \$\begingroup\$ I realized the pinouts were opposite and have mine mounted the other way. When I check DC voltage it just fluctuates constantly when the base is on, which prompted me to check AC voltage which stays at a constant .275V. Also, there is no AC part of this circuit. My arduino is hooked up to USB, and none of the circuit is AC so I'm not sure where interference would come from \$\endgroup\$ – joshua0823 Jan 18 '18 at 5:49
  • \$\begingroup\$ Is it connected to the controller? If not, the emitter and collector are floating. You're measuring electromagnetic noise in the environment. Try connecting collector to V+ through a resistor (10k) and emitter to ground. Then measure collector voltage when the base is high and low. \$\endgroup\$ – vofa Jan 18 '18 at 6:00
  • \$\begingroup\$ @vofa that was it. thanks. This still doesn't solve why it won't work with my controller though. When I connect the controller it doesn't do anything. The way it should operate is when the transistor is gated on it shorts the "x" button wire to ground and I have verified my solder connections on the controller work just fine without the Arduino. Do I need to maintain the Vcc connection to the collector when the controller is hooked up so the transistor will work as intended? \$\endgroup\$ – joshua0823 Jan 18 '18 at 6:09
  • \$\begingroup\$ @joshua0823 - I updated my answer \$\endgroup\$ – vofa Jan 18 '18 at 18:03
0
\$\begingroup\$

The difference between the SS8050 and BC547B is negligible.

The diagram is missing a wire.

enter image description here

Also, make sure you have the button connected the right way.

\$\endgroup\$
  • \$\begingroup\$ Their parameters have negligible difference, but their pinouts are reversed. That is a major difference. You are right about the missing wire. \$\endgroup\$ – vofa Jan 18 '18 at 17:44
  • \$\begingroup\$ Yeah I think this makes the most sense. I'm at work now but I'll add the wire when i get home and see if that's it. As for the buttons I know how they function and have them installed correctly. \$\endgroup\$ – joshua0823 Jan 19 '18 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.