1
\$\begingroup\$

I have started work on a new project of mine of building a simple 8-bit computer. Everything I have put together (clock, registers) has worked so far, until I needed to build RAM. For reference I have been using this site.

First, I'm using the 74LS189AN as a 64-bit random access memory, and I will use two of them to make a total of 16 bytes in my machine. I have hooked up one of the chips with the required 5V power supply and had the address data pins connected to ground along with the four digital inputs. The four outputs were connected to a hex inverter (74LS04) since the output on the 74LS189AN is inverted.

Then, the outputs of the 74LS04 are connected to four LEDs which connect to ground. The last few pins are the select and read/write pins. I connected the select to ground and the R/W pin to either high or low but had it set to low at the moment.

My problem is when I power on the chip as soon as I remove the R/W wire to Low then back to high the LEDs just keep on HIGH even though the digital inputs are LOW. After a few minutes, the chip itself begins to heat up so badly that it burns at the touch. What could be the problem; defective chip or am I reading the pin-out wrong?

enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ Number one would be to post a schematic. \$\endgroup\$ – MrGerber Jan 26 '18 at 6:18
6
\$\begingroup\$

Per your circuit description chip should not heat - there's no over-current drain, and no electrical conflicts at its outputs.

If you search over internet using query "74LS189AN heating", there's a video by Ben Eater exactly on the subject, with people comments (expand the replies on that page to see them):

Please, help me! When I put 3rd (WE) pin of 74LS189AN to the 5V, chip starts to heat up. Whats the problem?

...

Hi! I also have this same problem and have ordered from two different ebay sellers already and they are all faulty. I cheched Jameco but they do not ship to Finland. Anyone here have any other site where these can be ordered to Finland?

...

Same thing here. ordered replacements from jameco electronics in the US, they work fine. thanks!

...

I too decided to order more expensive 189's in the end from a UK seller (the batch that didn't work were a cheap Chinse import ... I know, I know). The replacement parts worked exactly as per the datasheet.

...

Here's comment from Ben's page you refer to in your question:

To whom it may concern, I purchased the 74LS189 chips from the Ebay link Ben provided. Specifically, I purchased them from a supplier called “j_k parts”. The chips did not work and heated up very quickly, I followed the RAM videos multiple times and consulted the datasheet to ensure I wired the chip correctly.

I found this article on Reddit today (http://www.righto.com/2017/08/inside-fake-ram-chip-i-found-something.html) about relabelled (counterfeit) TTL chips and the author specifically examines the 74LS189.

So question to you - where did you source yours?

\$\endgroup\$
  • 1
    \$\begingroup\$ I got mine from a ebay seller. So from your answer I will try to get a few of the chips from jameco since the ones I have are probably defective. Thank you! \$\endgroup\$ – diamondev Jan 26 '18 at 17:09
0
\$\begingroup\$

Two things to try:

First, you do not want the 7404 output to drive LED's without a current- limiting resistor. LED's are diodes and will pull down the outputs to their operating voltage, around 2 volts. Try adding a resistor to limit the current in the LED, so the 74LS04 won't get hot.

Second, put some pull-up resistors on the 74LS04 inputs. When you switch from write to read, the 74LS189 outputs switch to high impedance, so your 74LS04 inputs are floating. It is never good to allow inputs on these types of devices to float, or they can draw high current and get hot or even become damaged. TI has a pretty good discussion if you want to understand more:

http://www.ti.com/lit/an/scba004d/scba004d.pdf

Good luck!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.